summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Benjamin Trigona-Harany2018-11-13 02:06:42 +0100
committer Willy Sudiarto Raharjo2018-11-17 12:42:56 +0100
commit4fd6efbb433d7f91815ad5f43273bc39f386212e (patch)
tree7c554f34a00c0f05a24d98f27b302b27fddc6c65
parent05293f48dc3d6d933ee8a36c08f809ba11cdc302 (diff)
downloadslackbuilds-4fd6efbb433d7f91815ad5f43273bc39f386212e.tar.gz
python/timehash: Support Python 3.
-rw-r--r--python/timehash/timehash.SlackBuild23
-rw-r--r--python/timehash/timehash.info2
2 files changed, 14 insertions, 11 deletions
diff --git a/python/timehash/timehash.SlackBuild b/python/timehash/timehash.SlackBuild
index 17efab1989..3da0dad7a1 100644
--- a/python/timehash/timehash.SlackBuild
+++ b/python/timehash/timehash.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for timehash
-# Copyright 2016 Benjamin Trigona-Harany <slackbuilds@jaxartes.net>
+# Copyright 2016-2018 Benjamin Trigona-Harany <slackbuilds@jaxartes.net>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -24,12 +24,12 @@
PRGNAM=timehash
VERSION=${VERSION:-1.1}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
- i?86) ARCH=i486 ;;
+ i?86) ARCH=i586 ;;
arm*) ARCH=arm ;;
*) ARCH=$( uname -m ) ;;
esac
@@ -40,8 +40,8 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
@@ -67,15 +67,18 @@ find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
-o -perm 511 \) -exec chmod 755 {} \; -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python setup.py install --root=$PKG
+python2 setup.py install --root=$PKG
+python3 setup.py install --root=$PKG
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | \
- grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a CHANGES.md CONTRIBUTORS.md LICENSE README.rst $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ CHANGES.md CONTRIBUTORS.md LICENSE README.rst \
+ $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
diff --git a/python/timehash/timehash.info b/python/timehash/timehash.info
index 0a135ebfc8..4dae7daff5 100644
--- a/python/timehash/timehash.info
+++ b/python/timehash/timehash.info
@@ -5,6 +5,6 @@ DOWNLOAD="https://pypi.python.org/packages/source/t/timehash/timehash-1.1.tar.gz
MD5SUM="04168c401cd1114fa8784242ad3f6d6d"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES=""
+REQUIRES="python3"
MAINTAINER="Benjamin Trigona-Harany"
EMAIL="slackbuilds@jaxartes.net"