summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Alan Aversa2018-09-14 10:26:36 +0200
committer David Spencer2018-09-14 10:26:36 +0200
commitc441188f8df3d180729f58dcc7f882a738cf4a42 (patch)
tree2c0c92ca74c8f32415b6684d5fb78a7c197fad4f
parent75f3f030e1844487aae7a4ad69e1482ca782118b (diff)
downloadslackbuilds-c441188f8df3d180729f58dcc7f882a738cf4a42.tar.gz
academic/cryptominisat: Added (SAT solver).
Signed-off-by: David Spencer <idlemoor@slackbuilds.org>
-rw-r--r--academic/cryptominisat/README10
-rw-r--r--academic/cryptominisat/cryptominisat.SlackBuild104
-rw-r--r--academic/cryptominisat/cryptominisat.info10
-rw-r--r--academic/cryptominisat/slack-desc19
4 files changed, 143 insertions, 0 deletions
diff --git a/academic/cryptominisat/README b/academic/cryptominisat/README
new file mode 100644
index 0000000000..e87a6c10a4
--- /dev/null
+++ b/academic/cryptominisat/README
@@ -0,0 +1,10 @@
+CryptoMiniSat SAT solver
+
+This system provides CryptoMiniSat, an advanced SAT solver. The system
+has 3 interfaces: command-line, C++ library and python. The command-line
+interface takes a cnf as an input in the DIMACS format with the
+extension of XOR clauses. The C++ interface mimics this except that it
+allows for a more efficient system, with assumptions and multiple
+solve() calls. A C compatible wrapper is also provided. The python
+interface provides a high-level yet efficient API to use most of the C++
+interface with ease.
diff --git a/academic/cryptominisat/cryptominisat.SlackBuild b/academic/cryptominisat/cryptominisat.SlackBuild
new file mode 100644
index 0000000000..9cf9cd907a
--- /dev/null
+++ b/academic/cryptominisat/cryptominisat.SlackBuild
@@ -0,0 +1,104 @@
+#!/bin/sh
+
+# Slackware build script for cryptominisat
+
+# Copyright 2018 Alan Aversa USA
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=cryptominisat
+VERSION=${VERSION:-5.6.5}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+sed -i -e 's|share/man|man|' CMakeLists.txt
+
+mkdir -p build
+cd build
+ cmake \
+ -DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
+ -DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS" \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib${LIBDIRSUFFIX} \
+ -DUSE_GAUSS=ON \
+ -DCMAKE_BUILD_TYPE=Release ..
+ make
+ make install DESTDIR=$PKG
+cd ..
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+find $PKG/usr/man -type f -exec gzip -9 {} \;
+for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ AUTHORS LICENSE.txt README.markdown \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/academic/cryptominisat/cryptominisat.info b/academic/cryptominisat/cryptominisat.info
new file mode 100644
index 0000000000..fb235a35e9
--- /dev/null
+++ b/academic/cryptominisat/cryptominisat.info
@@ -0,0 +1,10 @@
+PRGNAM="cryptominisat"
+VERSION="5.6.5"
+HOMEPAGE="https://www.msoos.org/cryptominisat5/"
+DOWNLOAD="https://github.com/msoos/cryptominisat/archive/5.6.5/cryptominisat-5.6.5.tar.gz"
+MD5SUM="da3c44c7750842db4bd42c17f74387f4"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Alan Aversa"
+EMAIL="aveNOrsa@email.ariSPAMzona.edu"
diff --git a/academic/cryptominisat/slack-desc b/academic/cryptominisat/slack-desc
new file mode 100644
index 0000000000..2837ad1141
--- /dev/null
+++ b/academic/cryptominisat/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+cryptominisat: cryptominisat (SAT solver)
+cryptominisat:
+cryptominisat: This system provides CryptoMiniSat, an advanced SAT solver. The system
+cryptominisat: has 3 interfaces: command-line, C++ library and python. The
+cryptominisat: command-line interface takes a cnf as an input in the DIMACS format
+cryptominisat: with the extension of XOR clauses. The C++ interface mimics this
+cryptominisat: except that it allows for a more efficient system, with assumptions
+cryptominisat: and multiple solve() calls. A C compatible wrapper is also
+cryptominisat: provided. The python interface provides a high-level yet efficient API
+cryptominisat: to use most of the C++ interface with ease.
+cryptominisat: