summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Benjamin Trigona-Harany2018-07-16 18:48:48 +0200
committer Willy Sudiarto Raharjo2018-07-16 18:48:48 +0200
commit100b202453d1e4c30d2b82b56c6e15f5f8d99249 (patch)
tree626f1ba62f5d3f8a40d1b63d1a75fddeedb059d1
parent7e502e07dec6798d7452311f9f5d01e5c5dfaa56 (diff)
downloadslackbuilds-100b202453d1e4c30d2b82b56c6e15f5f8d99249.tar.gz
python/python-prometheus_client: Added (Prometheus instrumentation).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--python/python-prometheus_client/README2
-rw-r--r--python/python-prometheus_client/python-prometheus_client.SlackBuild89
-rw-r--r--python/python-prometheus_client/python-prometheus_client.info10
-rw-r--r--python/python-prometheus_client/slack-desc19
4 files changed, 120 insertions, 0 deletions
diff --git a/python/python-prometheus_client/README b/python/python-prometheus_client/README
new file mode 100644
index 0000000000..a03cef461d
--- /dev/null
+++ b/python/python-prometheus_client/README
@@ -0,0 +1,2 @@
+Prometheus is an open-source systems monitoring and alerting toolkit originally
+built at SoundCloud. This is the Python client for Prometheus.
diff --git a/python/python-prometheus_client/python-prometheus_client.SlackBuild b/python/python-prometheus_client/python-prometheus_client.SlackBuild
new file mode 100644
index 0000000000..9ba5035a35
--- /dev/null
+++ b/python/python-prometheus_client/python-prometheus_client.SlackBuild
@@ -0,0 +1,89 @@
+#!/bin/sh
+
+# Slackware build script for prometheus_client
+
+# Copyright 2018 Benjamin Trigona-Harany <slackbuilds@jaxartes.net>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=python-prometheus_client
+SRCNAM=client_python
+VERSION=${VERSION:-0.3.0}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+if $(python3 -c 'import sys' 2>/dev/null); then
+ python3 setup.py install --root=$PKG
+fi
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a LICENSE README.md $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/python-prometheus_client/python-prometheus_client.info b/python/python-prometheus_client/python-prometheus_client.info
new file mode 100644
index 0000000000..2735644d0d
--- /dev/null
+++ b/python/python-prometheus_client/python-prometheus_client.info
@@ -0,0 +1,10 @@
+PRGNAM="python-prometheus_client"
+VERSION="0.3.0"
+HOMEPAGE="https://prometheus.io/"
+DOWNLOAD="https://github.com/prometheus/client_python/archive/v0.3.0/client_python-0.3.0.tar.gz"
+MD5SUM="6e82f4283b40cb34946d53df3718c595"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Benjamin Trigona-Harany"
+EMAIL="slackbuilds@jaxartes.net"
diff --git a/python/python-prometheus_client/slack-desc b/python/python-prometheus_client/slack-desc
new file mode 100644
index 0000000000..ea220e7db2
--- /dev/null
+++ b/python/python-prometheus_client/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+python-prometheus_client: python-prometheus_client (Prometheus instrumentation library)
+python-prometheus_client:
+python-prometheus_client: Prometheus is an open-source systems monitoring and alerting toolkit
+python-prometheus_client: originally built at SoundCloud. This is the Python client for
+python-prometheus_client: Prometheus.
+python-prometheus_client:
+python-prometheus_client:
+python-prometheus_client:
+python-prometheus_client:
+python-prometheus_client:
+python-prometheus_client: