summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Edinaldo P. Silva2018-06-25 10:12:33 +0200
committer David Spencer2018-06-25 10:12:33 +0200
commitd8f1abf0d49ef60f9ff123ccb37de88dcb4d306f (patch)
tree36c2c9b43aaebae43f2925c451d4397b8ba57324
parentb899a2abfc02d4a7af88d631141bda59837e31b1 (diff)
downloadslackbuilds-d8f1abf0d49ef60f9ff123ccb37de88dcb4d306f.tar.gz
system/wine-staging: Updated for version 3.11.
Signed-off-by: David Spencer <idlemoor@slackbuilds.org>
-rw-r--r--system/wine-staging/harmony-fix.diff63
-rw-r--r--system/wine-staging/wine-binfmt.conf2
-rw-r--r--system/wine-staging/wine-staging.SlackBuild9
-rw-r--r--system/wine-staging/wine-staging.info10
4 files changed, 78 insertions, 6 deletions
diff --git a/system/wine-staging/harmony-fix.diff b/system/wine-staging/harmony-fix.diff
new file mode 100644
index 0000000000..fe0c8c929d
--- /dev/null
+++ b/system/wine-staging/harmony-fix.diff
@@ -0,0 +1,63 @@
+diff -u -r wine/dlls/gdi32/freetype.c wine-ft281/dlls/gdi32/freetype.c
+--- wine/dlls/gdi32/freetype.c 2017-10-04 18:01:36.000000000 +0200
++++ wine-ft281/dlls/gdi32/freetype.c 2017-10-10 10:29:17.506632615 +0200
+@@ -996,18 +996,23 @@
+
+ static BOOL is_subpixel_rendering_enabled( void )
+ {
+-#ifdef FT_LCD_FILTER_H
+ static int enabled = -1;
+ if (enabled == -1)
+ {
+- enabled = (pFT_Library_SetLcdFilter &&
+- pFT_Library_SetLcdFilter( NULL, 0 ) != FT_Err_Unimplemented_Feature);
++ /* >= 2.8.1 provides LCD rendering without filters */
++ if (FT_Version.major > 2 ||
++ FT_Version.major == 2 && FT_Version.minor > 8 ||
++ FT_Version.major == 2 && FT_Version.minor == 8 && FT_Version.patch >= 1)
++ enabled = TRUE;
++#ifdef FT_LCD_FILTER_H
++ else if (pFT_Library_SetLcdFilter &&
++ pFT_Library_SetLcdFilter( NULL, 0 ) != FT_Err_Unimplemented_Feature)
++ enabled = TRUE;
++#endif
++ else enabled = FALSE;
+ TRACE("subpixel rendering is %senabled\n", enabled ? "" : "NOT ");
+ }
+ return enabled;
+-#else
+- return FALSE;
+-#endif
+ }
+
+
+@@ -7271,7 +7276,6 @@
+ case WINE_GGO_HBGR_BITMAP:
+ case WINE_GGO_VRGB_BITMAP:
+ case WINE_GGO_VBGR_BITMAP:
+-#ifdef FT_LCD_FILTER_H
+ {
+ switch (ft_face->glyph->format)
+ {
+@@ -7357,8 +7361,11 @@
+ if ( needsTransform )
+ pFT_Outline_Transform (&ft_face->glyph->outline, &transMatTategaki);
+
++#ifdef FT_LCD_FILTER_H
+ if ( pFT_Library_SetLcdFilter )
+ pFT_Library_SetLcdFilter( library, FT_LCD_FILTER_DEFAULT );
++#endif
++
+ pFT_Render_Glyph (ft_face->glyph, render_mode);
+
+ src = ft_face->glyph->bitmap.buffer;
+@@ -7439,9 +7446,6 @@
+
+ break;
+ }
+-#else
+- return GDI_ERROR;
+-#endif
+
+ case GGO_NATIVE:
+ {
diff --git a/system/wine-staging/wine-binfmt.conf b/system/wine-staging/wine-binfmt.conf
new file mode 100644
index 0000000000..4d43073365
--- /dev/null
+++ b/system/wine-staging/wine-binfmt.conf
@@ -0,0 +1,2 @@
+# Start WINE on Windows executables
+:DOSWin:M::MZ::/usr/bin/wine:
diff --git a/system/wine-staging/wine-staging.SlackBuild b/system/wine-staging/wine-staging.SlackBuild
index 1f9804679f..36241a1d38 100644
--- a/system/wine-staging/wine-staging.SlackBuild
+++ b/system/wine-staging/wine-staging.SlackBuild
@@ -30,7 +30,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=wine-staging
-VERSION=${VERSION:-3.10}
+VERSION=${VERSION:-3.11}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -93,6 +93,10 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+# from Arch Linux PKGBUILD.
+patch -Np1 < $CWD/harmony-fix.diff
+sed 's|OpenCL/opencl.h|CL/opencl.h|g' -i configure*
+
# If OPENGL=YES above, then enable opengl; otherwise, disable it.
if [ "$OPENGL" = "YES" ]; then
do_opengl="with"
@@ -108,6 +112,8 @@ fi
--${do_opengl}-opengl \
--build=$ARCH-slackware-linux
+#NUMJOBS=${NUMJOBS:-" -j12 "}
+#make $NUMJOBS || exit 1
make
make install DESTDIR=$PKG
@@ -121,6 +127,7 @@ for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; r
install -d $PKG/etc/fonts/conf.{avail,d}
install -m644 $CWD/30-win32-aliases.conf $PKG/etc/fonts/conf.avail
ln -sf /etc/fonts/conf.avail/30-win32-aliases.conf $PKG/etc/fonts/conf.d/30-win32-aliases.conf
+install -Dm 644 $CWD/wine-binfmt.conf $PKG/usr/lib/binfmt.d/wine.conf
# Create Wine menu structure:
mkdir -p $PKG/etc/xdg/menus/applications-merged
diff --git a/system/wine-staging/wine-staging.info b/system/wine-staging/wine-staging.info
index e5b67042d6..9f069b7f94 100644
--- a/system/wine-staging/wine-staging.info
+++ b/system/wine-staging/wine-staging.info
@@ -1,10 +1,10 @@
PRGNAM="wine-staging"
-VERSION="3.10"
+VERSION="3.11"
HOMEPAGE="https://wiki.winehq.org/Wine-Staging"
-DOWNLOAD="https://dl.winehq.org/wine/source/3.x/wine-3.10.tar.xz \
- https://github.com/wine-staging/wine-staging/archive/v3.10/wine-staging-3.10.tar.gz"
-MD5SUM="eec9261ac33b46709f99537d359bd4ee \
- c0b369d69af1ab6ab1dafc5d517e3a84"
+DOWNLOAD="https://dl.winehq.org/wine/source/3.x/wine-3.11.tar.xz \
+ https://github.com/wine-staging/wine-staging/archive/v3.11/wine-staging-3.11.tar.gz"
+MD5SUM="34ffa2f1177207bdd92bafbc480db105 \
+ eda5725bb1702570e14b5bb2c6f23b55"
DOWNLOAD_x86_64="UNSUPPORTED"
MD5SUM_x86_64=""
REQUIRES=""