summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Matteo Bernardini2024-04-24 14:50:56 +0200
committer Willy Sudiarto Raharjo2024-04-27 04:28:39 +0200
commit84841703f62f1f2fda1659adb5b36f54aa9c68d5 (patch)
treedab2580ac50a38b4630f7aa6dfb0125919ebae5a
parentb28a21d276364357409655cb5c05f524c755b027 (diff)
downloadslackbuilds-84841703f62f1f2fda1659adb5b36f54aa9c68d5.tar.gz
desktop/lxpanel: Switch to gtk+3 by default.
Signed-off-by: Matteo Bernardini <ponce@slackbuilds.org> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--desktop/lxpanel/README6
-rw-r--r--desktop/lxpanel/lxpanel.SlackBuild19
-rw-r--r--desktop/lxpanel/lxpanel.info2
3 files changed, 20 insertions, 7 deletions
diff --git a/desktop/lxpanel/README b/desktop/lxpanel/README
index 14dd8a5e8a..1874d5d900 100644
--- a/desktop/lxpanel/README
+++ b/desktop/lxpanel/README
@@ -1 +1,7 @@
LXPanel is a NETWM/EWMH compliant lightweight X11 desktop panel.
+
+If you want to build this for gtk+2, pass to the script the switch
+
+ GTK3=no
+
+you will need the additional dependency keybinder in this case.
diff --git a/desktop/lxpanel/lxpanel.SlackBuild b/desktop/lxpanel/lxpanel.SlackBuild
index d1fd7184d5..853f3ce20f 100644
--- a/desktop/lxpanel/lxpanel.SlackBuild
+++ b/desktop/lxpanel/lxpanel.SlackBuild
@@ -3,7 +3,7 @@
# Slackware build script for lxpanel
# (C) 2008 Michael Wagner <lapinours@web.de>
-# Copyright 2011-2021 Matteo Bernardini <ponce@slackbuilds.org>, Pisa, Italy
+# Copyright 2011-2024 Matteo Bernardini <ponce@slackbuilds.org>, Pisa, Italy
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -29,7 +29,7 @@ cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=lxpanel
VERSION=${VERSION:-0.10.1}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -41,9 +41,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -67,6 +64,8 @@ else
LIBDIRSUFFIX=""
fi
+WITHGTK3="--enable-gtk3" ; [ "${GTK3:-yes}" = "no" ] && WITHGTK3=""
+
DOCS="AUTHORS COPYING ChangeLog README"
set -e
@@ -84,7 +83,14 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-sh autogen.sh || true
+if [ "$GTK3" = "yes" ]; then
+ # Disable pager plugin as it breaks panel layout with GTK+ 3
+ # https://sourceforge.net/p/lxde/bugs/773/
+ sed -i '/pager.c/d' plugins/Makefile.am
+ sed -i '/STATIC_PAGER/d' src/private.h
+ sed -i 's/libwnck-3.0//' configure.ac
+ autoreconf -fi
+fi
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
@@ -99,6 +105,7 @@ CXXFLAGS="$SLKCFLAGS" \
--program-suffix= \
--with-plugins=all \
--disable-silent-rules \
+ $WITHGTK3 \
--build=$ARCH-slackware-linux
make
diff --git a/desktop/lxpanel/lxpanel.info b/desktop/lxpanel/lxpanel.info
index acef8470ba..acb7f1aa94 100644
--- a/desktop/lxpanel/lxpanel.info
+++ b/desktop/lxpanel/lxpanel.info
@@ -5,6 +5,6 @@ DOWNLOAD="https://downloads.sf.net/lxde/lxpanel-0.10.1.tar.xz"
MD5SUM="c922d044789c3d7ae028f0e80dea18b0"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES="keybinder libfm"
+REQUIRES="libfm"
MAINTAINER="Matteo Bernardini"
EMAIL="ponce@slackbuilds.org"