summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Matteo Bernardini2023-02-12 19:55:44 +0100
committer Matteo Bernardini2024-04-20 17:22:38 +0200
commit0926043ad8bd3d62a6e6e6f72408e4ac5f80c30d (patch)
treec899d846c9e790214d7562825fe39e93e7d36bcb
parent7348664936073e3ad54706addd43560c23807ed8 (diff)
downloadslackbuilds-bamf.tar.gz
libraries/bamf: Updated for version 0.5.6.bamf
Signed-off-by: Matteo Bernardini <ponce@slackbuilds.org>
-rw-r--r--libraries/bamf/add_compile_warning_flags.patch71
-rw-r--r--libraries/bamf/bamf-no-gtester2xunit.patch22
-rw-r--r--libraries/bamf/bamf.SlackBuild6
-rw-r--r--libraries/bamf/bamf.info6
4 files changed, 28 insertions, 77 deletions
diff --git a/libraries/bamf/add_compile_warning_flags.patch b/libraries/bamf/add_compile_warning_flags.patch
deleted file mode 100644
index 203ccc75d3..0000000000
--- a/libraries/bamf/add_compile_warning_flags.patch
+++ /dev/null
@@ -1,71 +0,0 @@
-https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=940164
-
-diff -Naur bamf-0.5.4.orig/configure.ac bamf-0.5.4/configure.ac
---- bamf-0.5.4.orig/configure.ac 2018-11-07 23:39:11.355315678 +0100
-+++ bamf-0.5.4/configure.ac 2019-11-18 12:57:04.534000000 +0100
-@@ -18,14 +18,15 @@
- GNOME_COMPILE_WARNINGS(maximum)
-
- AM_MAINTAINER_MODE
--AM_DISABLE_STATIC
--AM_PROG_LIBTOOL
- AC_ISC_POSIX
- AC_SUBST(ACLOCAL_AMFLAFS, "$ACLOCAL_FLAGS -I m4")
-
- PKG_PROG_PKG_CONFIG
- if test "x$PKG_CONFIG" = "x"; then AC_MSG_ERROR([You need to install pkg-config]); fi
-
-+LT_INIT([disable-static])
-+LT_LIB_M
-+
- # Checks for programs.
- AC_PROG_CC
- AM_PROG_CC_C_O
-@@ -154,8 +155,39 @@
- #
- AM_PATH_GTK_3_0
-
-+# Compile warnings
-+AC_ARG_ENABLE(compile-warnings,
-+ AS_HELP_STRING([--enable-compile-warnings=@<:@no/minimum/yes/maximum/error@:>@],
-+ [Trun on compiler warnings]),,
-+ [enable_compile_warnings=maximum])
-+
-+warning_flags=
-+
-+case "$enable_compile_warnings" in
-+no)
-+warning_flags=
-+;;
-+minimum)
-+warning_flags="-Wall"
-+;;
-+yes)
-+warning_flags="-wall -Wno-error=deprecated-declarations"
-+;;
-+maximum|error)
-+warning_flags="-Wall -Wno-error=deprecated-declarations -Wempty-body -Wformat-security -Winit-self -Warray-bounds -Wimplicit-function-declaration"
-+if test "$enable_compile_warnings" = "error" ; then
-+ warning_flags="$warning_flags -Werror"
-+fi
-+;;
-+*)
-+AC_MSG_ERROR(Unknown argument '$enable_compile_warnings' to --enable-compile-warnings)
-+;;
-+esac
-+AC_MSG_CHECKING(what warning flags to pass to the C compiler)
-+AC_MSG_RESULT($warning_flags)
-+
- dnl CFLAGS
--CFLAGS="$CFLAGS -Wall -Werror -Wno-error=deprecated-declarations -Wempty-body -Wformat-security -Winit-self -Warray-bounds -Wimplicit-function-declaration -lm"
-+CFLAGS="$CFLAGS $warning_flags $LIBM"
-
- AC_SUBST(BAMFDAEMON_CFLAGS)
- AC_SUBST(BAMFDAEMON_LIBS)
-@@ -190,5 +222,6 @@
- Headless tests: ${enable_headless_tests}
- Coverage Reporting: ${use_gcov}
- Export actions menus: ${enable_export_actions_menu}
-+ Compiler Flags: ${CFLAGS}
-
- EOF
diff --git a/libraries/bamf/bamf-no-gtester2xunit.patch b/libraries/bamf/bamf-no-gtester2xunit.patch
new file mode 100644
index 0000000000..5c1e0fcd74
--- /dev/null
+++ b/libraries/bamf/bamf-no-gtester2xunit.patch
@@ -0,0 +1,22 @@
+diff -Naur bamf-0.5.6.orig/configure.ac bamf-0.5.6/configure.ac
+--- bamf-0.5.6.orig/configure.ac 2022-02-17 19:16:55.346057503 +0100
++++ bamf-0.5.6/configure.ac 2023-02-04 19:24:42.506720000 +0100
+@@ -106,18 +106,6 @@
+ GTK_DOC_CHECK(1.0)
+
+ ###########################
+-# gtester2xunit checks #
+-###########################
+-
+-AC_PATH_PROG([PYTHON],[python3])
+-AC_MSG_CHECKING(for gtester2xunit dependencies)
+-if !($PYTHON -c "from lxml import etree" 2> /dev/null); then
+- AC_MSG_RESULT([no])
+- AC_MSG_ERROR([You need to install python3-lxml]);
+-fi
+-AC_MSG_RESULT([yes])
+-
+-###########################
+ # Headless tests
+ ###########################
+ AC_ARG_ENABLE([headless-tests],
diff --git a/libraries/bamf/bamf.SlackBuild b/libraries/bamf/bamf.SlackBuild
index a381620ac1..38d46e792a 100644
--- a/libraries/bamf/bamf.SlackBuild
+++ b/libraries/bamf/bamf.SlackBuild
@@ -26,8 +26,8 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=bamf
-VERSION=${VERSION:-0.5.4}
-BUILD=${BUILD:-2}
+VERSION=${VERSION:-0.5.6}
+BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -80,7 +80,7 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-patch -p1 < $CWD/add_compile_warning_flags.patch
+patch -p1 < $CWD/bamf-no-gtester2xunit.patch
autoreconf -vif
CFLAGS="$SLKCFLAGS" \
diff --git a/libraries/bamf/bamf.info b/libraries/bamf/bamf.info
index 1effbc4410..b57453a2fe 100644
--- a/libraries/bamf/bamf.info
+++ b/libraries/bamf/bamf.info
@@ -1,8 +1,8 @@
PRGNAM="bamf"
-VERSION="0.5.4"
+VERSION="0.5.6"
HOMEPAGE="https://launchpad.net/bamf"
-DOWNLOAD="https://launchpad.net/bamf/0.5/0.5.4/+download/bamf-0.5.4.tar.gz"
-MD5SUM="e5078ec8f6c8a9d77242010dcd3b3217"
+DOWNLOAD="https://launchpad.net/bamf/0.5/0.5.6/+download/bamf-0.5.6.tar.gz"
+MD5SUM="49ed19dd5db0b4109f4dc2e4fe2ed13d"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="gnome-common"