summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author fourtysixandtwo2024-03-31 19:33:43 +0200
committer Willy Sudiarto Raharjo2024-04-05 10:18:13 +0200
commitce6ba4b031df1f987af55758709170d91111608d (patch)
tree9618bb75e20e7d547ca5fa19db3347fac655cc31
parent27ab275f39ef8b35a329c57c8daccb357ea1907d (diff)
downloadslackbuilds-ce6ba4b031df1f987af55758709170d91111608d.tar.gz
python/python3-daemon: Fix PYTHONPATH.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--python/python3-daemon/python3-daemon.SlackBuild3
1 files changed, 2 insertions, 1 deletions
diff --git a/python/python3-daemon/python3-daemon.SlackBuild b/python/python3-daemon/python3-daemon.SlackBuild
index 389acad97b..bfb082a12a 100644
--- a/python/python3-daemon/python3-daemon.SlackBuild
+++ b/python/python3-daemon/python3-daemon.SlackBuild
@@ -80,7 +80,8 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-export PYTHONPATH=/opt/python3.9/site-packages/
+PYVER=$(python3 -c 'import sys; print("%d.%d" % sys.version_info[:2])')
+export PYTHONPATH=/opt/python$PYVER/site-packages/
## If your application only has a pyproject.toml:
python3 -m build --wheel --no-isolation