summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Willy Sudiarto Raharjo2024-04-24 14:25:17 +0200
committer Willy Sudiarto Raharjo2024-04-24 14:25:17 +0200
commitb36f8e1e5156f53f64827fd4e77b41215c6fdd2e (patch)
tree6d4942535601276fc412989cd13a898804d127fe
parent0c6a1f6d6841487f500622fa990ec533f5ac0b72 (diff)
downloadslackbuilds-b36f8e1e5156f53f64827fd4e77b41215c6fdd2e.tar.gz
games/PyLotRO: Removed (FTBFS and upstream no longer updated)
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--games/PyLotRO/HTTPSConnectionFix.patch22
-rw-r--r--games/PyLotRO/PyLotRO.SlackBuild86
-rw-r--r--games/PyLotRO/PyLotRO.info10
-rw-r--r--games/PyLotRO/README11
-rw-r--r--games/PyLotRO/doinst.sh3
-rw-r--r--games/PyLotRO/slack-desc19
6 files changed, 0 insertions, 151 deletions
diff --git a/games/PyLotRO/HTTPSConnectionFix.patch b/games/PyLotRO/HTTPSConnectionFix.patch
deleted file mode 100644
index 96f6889037..0000000000
--- a/games/PyLotRO/HTTPSConnectionFix.patch
+++ /dev/null
@@ -1,22 +0,0 @@
---- PyLotROLauncher/PyLotROUtils.py 2012-11-28 20:06:06.000000000 -0600
-+++ PyLotROLauncher/PyLotROUtils.py 2013-06-04 21:08:53.032626141 -0500
-@@ -37,6 +37,7 @@
- # If Python 3.0 is in use use http otherwise httplib
- if sys.version_info[:2] < (3, 0):
- from httplib import HTTPConnection, HTTPSConnection
-+ import ssl, socket
- from urllib import quote
- else:
- from http.client import HTTPConnection, HTTPSConnection
-@@ -50,7 +51,10 @@
- else:
- url = urlIn[8:].split("/")[0]
- post = urlIn[8:].replace(url, "")
-- return HTTPSConnection(url), post
-+ conn = HTTPSConnection(url)
-+ sock = socket.create_connection((conn.host, conn.port), conn.timeout, conn.source_address)
-+ conn.sock = ssl.wrap_socket(sock, conn.key_file, conn.cert_file, ssl_version=ssl.PROTOCOL_TLSv1)
-+ return conn, post
-
- def GetText(nodelist):
- rc = ""
diff --git a/games/PyLotRO/PyLotRO.SlackBuild b/games/PyLotRO/PyLotRO.SlackBuild
deleted file mode 100644
index 7ed7653ec5..0000000000
--- a/games/PyLotRO/PyLotRO.SlackBuild
+++ /dev/null
@@ -1,86 +0,0 @@
-#!/bin/bash
-
-# Slackbuild for PyLotRO
-
-# Slackbuild is released under the Dog-on-Fire License:
-# If use of this script causes your dog to catch on fire,
-# you agree to send me five dollars. Or a picture
-# of the dog on fire.
-# Otherwise, you're on your own. I've tested the script
-# on my own computer, and it hasn't broken anything.
-# So if it does it on your computer, that falls in
-# the realm of "Not my problem."
-#
-# Of course, if you'll send a bug report to the above
-# email address, I may be able to see what you did
-# wrong and prevent it from happening in the future.
-# In which case, I may just send YOU five dollars.
-
-# Oh, and feel free to copy it and modify it as you
-# see fit. Or as I see fit. Or as I fit. Although
-# that is unlikely, as I am rather tall.
-
-
-cd $(dirname $0) ; CWD=$(pwd)
-
-PRGNAM=PyLotRO
-VERSION=${VERSION:-0.1.15}
-BUILD=${BUILD:-2}
-TAG=${TAG:-_SBo}
-PKGTYPE=${PKGTYPE:-tgz}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
-if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
- echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
- exit 0
-fi
-
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$VERSION
-unzip $CWD/$PRGNAM-$VERSION.zip
-mv $PRGNAM $PRGNAM-$VERSION
-cd $PRGNAM-$VERSION
-
-patch -p0 < $CWD/HTTPSConnectionFix.patch
-
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
-
-python setup.py build
-python setup.py install --root $PKG
-
-find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a AUTHORS COPYING ChangeLog README $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-cat $CWD/doinst.sh > $PKG/install/doinst.sh
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/games/PyLotRO/PyLotRO.info b/games/PyLotRO/PyLotRO.info
deleted file mode 100644
index bc5d8424d2..0000000000
--- a/games/PyLotRO/PyLotRO.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="PyLotRO"
-VERSION="0.1.15"
-HOMEPAGE="https://sites.google.com/site/leeslinuxblog/installing-lotro-in-wine"
-DOWNLOAD="https://sites.google.com/site/leeslinuxblog/PyLotRO-0.1.15.zip"
-MD5SUM="0020630b0be1ae8cee075e994c4feb8d"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES=""
-MAINTAINER="JK Wood"
-EMAIL="joshuakwood[at]gmail.com"
diff --git a/games/PyLotRO/README b/games/PyLotRO/README
deleted file mode 100644
index cbed665fa7..0000000000
--- a/games/PyLotRO/README
+++ /dev/null
@@ -1,11 +0,0 @@
-PyLotRO is a launcher for The Lord of the Rings Online and Dungeons
-and Dragons Online for Linux and Mac OSX. This application gives a
-graphical interface that allows both starting and patching/updating
-the game when installed in Wine.
-
-The homepage for PyLotRO disappeared some time ago, but no further
-development appears to be necessary.
-
-PyLotRO does not have any extra build dependencies beyond those
-present in a full install of Slackware, but wine is required to
-actually play either LOTRO or DDO.
diff --git a/games/PyLotRO/doinst.sh b/games/PyLotRO/doinst.sh
deleted file mode 100644
index 5fb28930db..0000000000
--- a/games/PyLotRO/doinst.sh
+++ /dev/null
@@ -1,3 +0,0 @@
-if [ -x /usr/bin/update-desktop-database ]; then
- /usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
-fi
diff --git a/games/PyLotRO/slack-desc b/games/PyLotRO/slack-desc
deleted file mode 100644
index 471a87d1b8..0000000000
--- a/games/PyLotRO/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-PyLotRO: PyLotRO (Python launcher of Lord of the Rings Online)
-PyLotRO:
-PyLotRO: PyLotRO is a launcher for the Lord of the Rings Online MMO written
-PyLotRO: in Python. It allows patching and beginning the game under Linux
-PyLotRO: when installed in wine.
-PyLotRO: PyLotRO should also work with Dungeons and Dragons Online (DDO).
-PyLotRO:
-PyLotRO: Homepage:
-PyLotRO: https://sites.google.com/site/leeslinuxblog/installing-lotro-in-wine
-PyLotRO:
-PyLotRO: