summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author fourtysixandtwo2024-03-31 14:20:55 +0200
committer Willy Sudiarto Raharjo2024-04-05 10:18:07 +0200
commit764268d8513519184823b94466a2d54b917708da (patch)
tree8f02c3fcbd4c8829ce41780ea20d5c776050c7ec
parente8da3b1b6076a6e4af65e3ec6c48368e5d2f76fd (diff)
downloadslackbuilds-764268d8513519184823b94466a2d54b917708da.tar.gz
python/python3-autocommand: Fix build on current.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--python/python3-autocommand/python3-autocommand.SlackBuild30
-rw-r--r--python/python3-autocommand/python3-autocommand.info2
2 files changed, 9 insertions, 23 deletions
diff --git a/python/python3-autocommand/python3-autocommand.SlackBuild b/python/python3-autocommand/python3-autocommand.SlackBuild
index 171e163138..5b65e05495 100644
--- a/python/python3-autocommand/python3-autocommand.SlackBuild
+++ b/python/python3-autocommand/python3-autocommand.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for python3-autocommand
-# Copyright 2022 fourtysixandtwo <fourtysixandtwo@sliderr.net>
+# Copyright 2022-2024 fourtysixandtwo <fourtysixandtwo@sliderr.net>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -26,7 +26,6 @@ cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=python3-autocommand
SRCNAM=${PRGNAM#python3-*}
-SRCNAM=${PRGNAM#python3-*}
VERSION=${VERSION:-2.2.2}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -40,9 +39,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -52,20 +48,6 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
set -e
rm -rf $PKG
@@ -77,11 +59,15 @@ cd $SRCNAM-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
+ -o -perm 511 \) -exec chmod 755 {} \+ -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \+
+
+# PEP 621 fix for license https://github.com/Lucretiel/autocommand/pull/31
+sed -i '/^\[project.urls/i dynamic = \[ "license" \]\n' pyproject.toml
-python3 setup.py install --root=$PKG
+python3 -m build --no-isolation
+python3 -m installer --destdir "$PKG" dist/*.whl
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
diff --git a/python/python3-autocommand/python3-autocommand.info b/python/python3-autocommand/python3-autocommand.info
index 7a3f226b07..5e0f783da7 100644
--- a/python/python3-autocommand/python3-autocommand.info
+++ b/python/python3-autocommand/python3-autocommand.info
@@ -5,6 +5,6 @@ DOWNLOAD="https://files.pythonhosted.org/packages/source/a/autocommand/autocomma
MD5SUM="0cab5141bad0dfb363b086e93fd4125e"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES=""
+REQUIRES="python3-build python3-wheel"
MAINTAINER="fourtysixandtwo"
EMAIL="fourtysixandtwo@sliderr.net"