summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Dimitris Zlatanidis2022-06-27 23:56:06 +0200
committer Willy Sudiarto Raharjo2022-07-02 04:55:46 +0200
commit39bd717f73a5dec1410436dca38906eb8031fcef (patch)
treee0d23b467a2971f0e5201718fe51a2b1e2ba1678
parent5804d0f7e99be44ed3a74f4d8acd1030946bfccc (diff)
downloadslackbuilds-39bd717f73a5dec1410436dca38906eb8031fcef.tar.gz
network/twine: Updated for version 4.0.1.
Signed-off-by: Dimitris Zlatanidis <d.zlatanidis@gmail.com> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--network/twine/setup.py5
-rw-r--r--network/twine/twine.SlackBuild5
-rw-r--r--network/twine/twine.info8
3 files changed, 12 insertions, 6 deletions
diff --git a/network/twine/setup.py b/network/twine/setup.py
new file mode 100644
index 0000000000..0ae4555937
--- /dev/null
+++ b/network/twine/setup.py
@@ -0,0 +1,5 @@
+from setuptools import setup
+
+
+if __name__ == '__main__':
+ setup()
diff --git a/network/twine/twine.SlackBuild b/network/twine/twine.SlackBuild
index d477c3e17e..aecaa10aa3 100644
--- a/network/twine/twine.SlackBuild
+++ b/network/twine/twine.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for twine
-# Copyright 2016-2019 Dimitris Zlatanidis Orestiada, Greece
+# Copyright 2016-2022 Dimitris Zlatanidis Orestiada, Greece
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -25,7 +25,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=twine
-VERSION=${VERSION:-3.1.1}
+VERSION=${VERSION:-4.0.1}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -71,6 +71,7 @@ mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cp $CWD/setup.py $PRGNAM-$VERSION
cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
diff --git a/network/twine/twine.info b/network/twine/twine.info
index a5949c4cce..cb07e37faa 100644
--- a/network/twine/twine.info
+++ b/network/twine/twine.info
@@ -1,10 +1,10 @@
PRGNAM="twine"
-VERSION="3.1.1"
+VERSION="4.0.1"
HOMEPAGE="https://github.com/pypa/twine"
-DOWNLOAD="https://files.pythonhosted.org/packages/7e/2f/e2a91a8ab97e8c9830ce297132631aef5dcd599f076123d1ebb26f1941b6/twine-3.1.1.tar.gz"
-MD5SUM="faf033a3458de37df6cdecceb6da2c2b"
+DOWNLOAD="https://files.pythonhosted.org/packages/08/2a/e03c20f47c750699063bbb349d68dea8990a0694f7bc65d1a97bf3254fa7/twine-4.0.1.tar.gz"
+MD5SUM="a5df863a1f307a21156387d8506390ad"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES="tqdm pkginfo requests-toolbelt readme_renderer python-zipp python-keyring"
+REQUIRES="pkginfo requests-toolbelt readme_renderer python-keyring python-importlib_metadata python3-rfc3986 python3-rich"
MAINTAINER="Dimitris Zlatanidis"
EMAIL="d.zlatanidis@gmail.com"