summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Martin Bångens2022-07-02 02:56:38 +0200
committer Willy Sudiarto Raharjo2022-07-02 04:55:35 +0200
commit05031e58e36cbb5ab2c5ac8065103759a16f90eb (patch)
treed04739df8bc6c66f47902a1e40adfdc647ffaf8b
parent4fbbba5918d9bd706f51b72d1e4dff96f755bede (diff)
downloadslackbuilds-05031e58e36cbb5ab2c5ac8065103759a16f90eb.tar.gz
libraries/vst3sdk: Added (SDK for VST3 plug-ins)
Signed-off-by: Dave Woodfall <dave@slackbuilds.org> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--libraries/vst3sdk/README22
-rw-r--r--libraries/vst3sdk/slack-desc19
-rw-r--r--libraries/vst3sdk/vst3sdk.SlackBuild89
-rw-r--r--libraries/vst3sdk/vst3sdk.info10
-rw-r--r--libraries/vst3sdk/vst3sdk.pc5
5 files changed, 145 insertions, 0 deletions
diff --git a/libraries/vst3sdk/README b/libraries/vst3sdk/README
new file mode 100644
index 0000000000..83b9734c38
--- /dev/null
+++ b/libraries/vst3sdk/README
@@ -0,0 +1,22 @@
+A VST plug-in is an audio processing component that is utilized within
+a host application. This host application provides the audio or/and
+event streams that are processed by the plug-in's code. Generally
+speaking, a VST plug-in can take a stream of audio data, apply a
+process to the audio, and return the result to the host application.
+A VST Plug-in performs its process normally using the processor of the
+computer. The audio stream is broken down into a series of blocks. The
+host supplies the blocks in sequence. The host and its current
+environment control the block-size. The VST Plug-in maintains the
+status of all its own parameters relating to the running process: The
+host does not maintain any information about what the Plug-in did with
+the last block of data it processed.
+
+From the host application's point of view, a VST plug-in is a black box
+with an arbitrary number of inputs, outputs (Event (MIDI) or Audio),
+and associated parameters. The host needs no implicit knowledge of the
+plug-in's process to be able to use it. The Plug-in process can use
+whatever parameters it wishes, internally to the process, but depending
+on the capabilities of the host, it can allow the changes to user
+parameters to be automated by the host.
+
+Details on how to use are found at www.steinberg.net/sdklicenses_vst3
diff --git a/libraries/vst3sdk/slack-desc b/libraries/vst3sdk/slack-desc
new file mode 100644
index 0000000000..c70562a6a4
--- /dev/null
+++ b/libraries/vst3sdk/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+vst3sdk: vst3sdk (Software development kit for VST3 plug-ins)
+vst3sdk:
+vst3sdk: This allows plug-in developers to create plug-ins in VST 3 format and
+vst3sdk: host developers to load VST 3 plug-ins into a DAW or audio editor.
+vst3sdk:
+vst3sdk:
+vst3sdk:
+vst3sdk:
+vst3sdk:
+vst3sdk:
+vst3sdk:
diff --git a/libraries/vst3sdk/vst3sdk.SlackBuild b/libraries/vst3sdk/vst3sdk.SlackBuild
new file mode 100644
index 0000000000..8f981d88f1
--- /dev/null
+++ b/libraries/vst3sdk/vst3sdk.SlackBuild
@@ -0,0 +1,89 @@
+#!/bin/bash
+
+# Slackware build script for vst3sdk
+
+# Copyright Martin Bångens Sweden
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+cd $(dirname $0) ; CWD=$(pwd)
+
+PRGNAM=vst3sdk
+VERSION=${VERSION:-3.7.5}
+SDK_BUILD=${SDK_BUILD:-_build_44}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
+ARCH=noarch
+
+# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
+# the name of the created package would be, and then exit. This information
+# could be useful to other scripts.
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+
+#handle if its 32bit but this should be in lib64 but lib: is not set
+mkdir -p $PKG/usr/lib/pkgconfig
+cp $CWD/vst3sdk.pc $PKG/usr/lib/pkgconfig/
+sed -i "s/VERSION/$VERSION_$SDK_BUILD/g" $PKG/usr/lib/pkgconfig/vst3sdk.pc
+
+mkdir -p $PKG/usr/include/vst3sdk
+cp -a base $PKG/usr/include/vst3sdk/
+cp -a cmake $PKG/usr/include/vst3sdk/
+cp -a pluginterfaces $PKG/usr/include/vst3sdk/
+cp -a public.sdk $PKG/usr/include/vst3sdk/
+cp -a vstgui4 $PKG/usr/include/vst3sdk/
+cp CMakeLists.txt $PKG/usr/include/vst3sdk/
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ doc/ \
+ LICENSE.txt \
+ README.md \
+ VST3_License_Agreement.pdf \
+ VST3_Usage_Guidelines.pdf \
+ index.html \
+$PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+chmod -R 644 $PKG/usr/include/vst3sdk
+chmod -R 644 $PKG/usr/doc/$PRGNAM-$VERSION
+find $PKG/usr/doc/$PRGNAM-$VERSION -type d -exec chmod 755 {} +
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/libraries/vst3sdk/vst3sdk.info b/libraries/vst3sdk/vst3sdk.info
new file mode 100644
index 0000000000..750a3979d1
--- /dev/null
+++ b/libraries/vst3sdk/vst3sdk.info
@@ -0,0 +1,10 @@
+PRGNAM="vst3sdk"
+VERSION="3.7.5"
+HOMEPAGE="https://www.steinberg.net/developers/"
+DOWNLOAD="https://github.com/noisecode3/vst3sdk/archive/3.7.5/vst3sdk-3.7.5.tar.gz"
+MD5SUM="a7df29111d04d8781f10fed31bd26a3f"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Martin Bångens"
+EMAIL="marbangens@gmail.com"
diff --git a/libraries/vst3sdk/vst3sdk.pc b/libraries/vst3sdk/vst3sdk.pc
new file mode 100644
index 0000000000..03d3ba8845
--- /dev/null
+++ b/libraries/vst3sdk/vst3sdk.pc
@@ -0,0 +1,5 @@
+Name: vst3sdk
+Description: VST 3 Plug-In SDK
+Version: VERSION
+Cflags: -I/usr/include/vst3sdk
+Libs: