summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Matteo Bernardini2024-01-06 11:30:29 +0100
committer Matteo Bernardini2024-03-23 09:16:41 +0100
commit7a63404115812fe8890d2195a6e8738684f9c530 (patch)
tree15e540906a5e6686d94e1cbf7fc974555de40fb0
parentecfbf772e938e6dfdc25bbce4ec902ad04952af9 (diff)
downloadslackbuilds-Sphinx.tar.gz
development/Sphinx: Removed (added to Slackware as python-sphinx).Sphinx
Signed-off-by: Matteo Bernardini <ponce@slackbuilds.org>
-rw-r--r--development/Sphinx/README5
-rw-r--r--development/Sphinx/Sphinx.SlackBuild87
-rw-r--r--development/Sphinx/Sphinx.info10
-rw-r--r--development/Sphinx/slack-desc19
4 files changed, 0 insertions, 121 deletions
diff --git a/development/Sphinx/README b/development/Sphinx/README
deleted file mode 100644
index e3f923a7f7..0000000000
--- a/development/Sphinx/README
+++ /dev/null
@@ -1,5 +0,0 @@
-Sphinx is a tool that translates a set of reStructuredText
-source files into various output formats, including HTML, ePub,
-LaTeX and plain text. Sphinx was originally created for the Python
-documentation, but it has excellent facilities for the documentation
-of software projects in a range of languages.
diff --git a/development/Sphinx/Sphinx.SlackBuild b/development/Sphinx/Sphinx.SlackBuild
deleted file mode 100644
index 330564c274..0000000000
--- a/development/Sphinx/Sphinx.SlackBuild
+++ /dev/null
@@ -1,87 +0,0 @@
-#!/bin/bash
-
-# Slackware build script for Sphinx
-
-# Copyright 2023-2024 fourtysixandtwo <fourtysixandtwo@sliderr.net>
-# Copyright 2013 Mikko Värri, Finland
-# Copyright 2017-2021 Benjamin Trigona-Harany <slackbuilds@jaxartes.net>
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-cd $(dirname $0) ; CWD=$(pwd)
-
-PRGNAM=Sphinx
-SRCNAM=Sphinx
-VERSION=${VERSION:-5.3.0}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-PKGTYPE=${PKGTYPE:-tgz}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
- echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
- exit 0
-fi
-
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $SRCNAM-$VERSION
-tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
-cd $SRCNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \+ -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \+
-
-# lower Pygments required version
-sed -i '/Pygments>=/ s/2.12/2.10.0/' pyproject.toml
-
-python3 -m build --no-isolation
-python3 -m installer -d "$PKG" dist/*.whl
-
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a \
- AUTHORS CHANGES EXAMPLES LICENSE README.rst \
- $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/development/Sphinx/Sphinx.info b/development/Sphinx/Sphinx.info
deleted file mode 100644
index 9d05ca57e9..0000000000
--- a/development/Sphinx/Sphinx.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="Sphinx"
-VERSION="5.3.0"
-HOMEPAGE="http://www.sphinx-doc.org"
-DOWNLOAD="https://files.pythonhosted.org/packages/source/S/Sphinx/Sphinx-5.3.0.tar.gz"
-MD5SUM="b752f7b0177865a36cbcdcef4ac80cd4"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES="alabaster imagesize python3-babel snowballstemmer sphinxcontrib-applehelp sphinxcontrib-devhelp sphinxcontrib-htmlhelp sphinxcontrib-jsmath sphinxcontrib-qthelp sphinxcontrib-serializinghtml python-importlib_metadata"
-MAINTAINER="fourtysixandtwo"
-EMAIL="fourtysixandtwo@sliderr.net"
diff --git a/development/Sphinx/slack-desc b/development/Sphinx/slack-desc
deleted file mode 100644
index 403648f0ae..0000000000
--- a/development/Sphinx/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-Sphinx: Sphinx (Documentation generator)
-Sphinx:
-Sphinx: Sphinx is a tool that translates a set of reStructuredText source
-Sphinx: files into various output formats, including HTML, ePub, LaTeX and
-Sphinx: plain text. Sphinx was originally created for the Python
-Sphinx: documentation, but it has excellent facilities for the documentation
-Sphinx: of software projects in a range of languages.
-Sphinx:
-Sphinx:
-Sphinx:
-Sphinx: