summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author B. Watson2021-11-29 20:02:31 +0100
committer Willy Sudiarto Raharjo2021-12-04 04:09:05 +0100
commita19b873616fd7577ddfae7b735d04c9ff7a4db3d (patch)
treee45ebe2368e6f634c07b300a97b409d7e87b3758
parent2ff1ca3bd954e9434aaf70a145cc6bdcf062fbca (diff)
downloadslackbuilds-a19b873616fd7577ddfae7b735d04c9ff7a4db3d.tar.gz
audio/gtklick: New-style icons.
Signed-off-by: B. Watson <yalhcru@gmail.com> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--audio/gtklick/doinst.sh6
-rw-r--r--audio/gtklick/gtklick.SlackBuild18
2 files changed, 15 insertions, 9 deletions
diff --git a/audio/gtklick/doinst.sh b/audio/gtklick/doinst.sh
index 5fb28930db..3e5691a052 100644
--- a/audio/gtklick/doinst.sh
+++ b/audio/gtklick/doinst.sh
@@ -1,3 +1,9 @@
if [ -x /usr/bin/update-desktop-database ]; then
/usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
fi
+
+if [ -e usr/share/icons/hicolor/icon-theme.cache ]; then
+ if [ -x /usr/bin/gtk-update-icon-cache ]; then
+ /usr/bin/gtk-update-icon-cache usr/share/icons/hicolor >/dev/null 2>&1
+ fi
+fi
diff --git a/audio/gtklick/gtklick.SlackBuild b/audio/gtklick/gtklick.SlackBuild
index 8c0b052ff7..a78d9ffac5 100644
--- a/audio/gtklick/gtklick.SlackBuild
+++ b/audio/gtklick/gtklick.SlackBuild
@@ -6,11 +6,13 @@
# Licensed under the WTFPL. See http://www.wtfpl.net/txt/copying/ for details.
+# 20211129 bkw: BUILD=2, new-style icon.
+
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=gtklick
VERSION=${VERSION:-0.6.4}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -22,9 +24,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -57,14 +56,15 @@ rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+find -L . -perm /111 -a \! -perm 755 -a -exec chmod 755 {} \+ -o \
+ \! -perm /111 -a \! -perm 644 -a -exec chmod 644 {} \+
python setup.py install --root=$PKG
+mkdir -p $PKG/usr/share/icons/hicolor/48x48/apps
+mv $PKG/usr/share/pixmaps/$PRGNAM.png $PKG/usr/share/icons/hicolor/48x48/apps
+ln -s ../icons/hicolor/48x48/apps/$PRGNAM.png $PKG/usr/share/pixmaps/$PRGNAM.png
+
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a [A-Z]* $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild