summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Tim Dickson2022-07-15 18:53:19 +0200
committer Willy Sudiarto Raharjo2022-07-17 01:40:07 +0200
commit2c1bdc5aea3bcbb22aa9b5ad07ce72890ddd7ba9 (patch)
tree19e4d8993f6f85854b68877bf2bf91a6dc777c31
parent7a8d59f5126de33dba917998c8830dedb4331632 (diff)
downloadslackbuilds-2c1bdc5aea3bcbb22aa9b5ad07ce72890ddd7ba9.tar.gz
libraries/gsm: Updated for version 1.0.20.
Signed-off-by: Dave Woodfall <dave@slackbuilds.org> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--libraries/gsm/Makefile.patch (renamed from libraries/gsm/patches/gsm-1.0.19-shared.patch)44
-rw-r--r--libraries/gsm/gsm-1.0.12-memcpy.patch (renamed from libraries/gsm/patches/gsm-1.0.12-memcpy.patch)0
-rw-r--r--libraries/gsm/gsm.SlackBuild25
-rw-r--r--libraries/gsm/gsm.info6
-rw-r--r--libraries/gsm/patches/gsm-1.0.12-64bit.patch16
5 files changed, 45 insertions, 46 deletions
diff --git a/libraries/gsm/patches/gsm-1.0.19-shared.patch b/libraries/gsm/Makefile.patch
index 3a9141c698..97bc4758a4 100644
--- a/libraries/gsm/patches/gsm-1.0.19-shared.patch
+++ b/libraries/gsm/Makefile.patch
@@ -1,7 +1,15 @@
-diff -ur gsm-1.0-pl13.orig/Makefile gsm-1.0-pl13/Makefile
---- gsm-1.0-pl19.orig/Makefile 2006-04-26 22:14:26.000000000 +0300
-+++ gsm-1.0-pl19/Makefile 2009-09-08 14:50:02.000000000 +0300
-@@ -96,7 +96,7 @@
+--- Makefile.orig 2022-07-03 18:49:29.000000000 +0100
++++ Makefile 2022-07-15 15:06:58.340000000 +0100
+@@ -75,6 +75,8 @@
+
+ # What's this release's version? Part of the directory and archive file name.
+ VERSION = 1.0-pl20
++# VER is used as the actual lib version
++VER ?= 1.0.20
+
+ # Where do you want to install the gsm library, header file, and manpages?
+ #
+@@ -99,7 +101,7 @@
# Other tools
SHELL = /bin/sh
@@ -9,8 +17,8 @@ diff -ur gsm-1.0-pl13.orig/Makefile gsm-1.0-pl13/Makefile
+LN = ln -s
BASENAME = basename
AR = ar
- ARFLAGS = cr
-@@ -140,6 +140,7 @@
+ ARFLAGS = cr
+@@ -143,6 +145,7 @@
# Targets
LIBGSM = $(LIB)/libgsm.a
@@ -18,7 +26,7 @@ diff -ur gsm-1.0-pl13.orig/Makefile gsm-1.0-pl13/Makefile
TOAST = $(BIN)/toast
UNTOAST = $(BIN)/untoast
-@@ -203,24 +204,43 @@
+@@ -206,24 +209,43 @@
# Object files
@@ -80,7 +88,7 @@ diff -ur gsm-1.0-pl13.orig/Makefile gsm-1.0-pl13/Makefile
TOAST_OBJECTS = $(SRC)/toast.o \
$(SRC)/toast_lin.o \
-@@ -228,7 +248,7 @@
+@@ -231,7 +253,7 @@
$(SRC)/toast_alaw.o \
$(SRC)/toast_audio.o
@@ -89,7 +97,7 @@ diff -ur gsm-1.0-pl13.orig/Makefile gsm-1.0-pl13/Makefile
# Manuals
-@@ -277,9 +297,12 @@
+@@ -280,9 +302,12 @@
$(CC) $(CFLAGS) $?
@-mv `$(BASENAME) $@` $@ > /dev/null 2>&1
@@ -103,15 +111,15 @@ diff -ur gsm-1.0-pl13.orig/Makefile gsm-1.0-pl13/Makefile
@-echo $(ROOT): Done.
tst: $(TST)/lin2cod $(TST)/cod2lin $(TOAST) $(TST)/test-result
-@@ -299,24 +322,29 @@
+@@ -302,24 +327,29 @@
# The basic API: libgsm
-$(LIBGSM): $(LIB) $(GSM_OBJECTS)
+$(LIBGSMSO): $(LIB) $(SHARED_GSM_OBJECTS)
-+ $(LD) $(LFLAGS) -o $@.1.0.19 -shared -Xlinker -soname -Xlinker libgsm.so.1 $(SHARED_GSM_OBJECTS) -lc
-+ ln -fs libgsm.so.1.0.19 lib/libgsm.so.1
-+ ln -fs libgsm.so.1.0.19 lib/libgsm.so
++ $(LD) $(LFLAGS) -o $@.${VER} -shared -Xlinker -soname -Xlinker libgsm.so.1 $(SHARED_GSM_OBJECTS) -lc
++ ln -fs libgsm.so.${VER} lib/libgsm.so.1
++ ln -fs libgsm.so.${VER} lib/libgsm.so
+
+$(LIBGSM): $(LIB) $(STATIC_GSM_OBJECTS)
-rm $(RMFLAGS) $(LIBGSM)
@@ -138,14 +146,14 @@ diff -ur gsm-1.0-pl13.orig/Makefile gsm-1.0-pl13/Makefile
# The local bin and lib directories
-@@ -426,7 +454,9 @@
+@@ -429,7 +459,9 @@
clean: semi-clean
-rm $(RMFLAGS) $(LIBGSM) $(ADDTST)/add \
- $(TOAST) $(TCAT) $(UNTOAST) \
-+ $(LIBGSMSO) $(LIB)/libgsm.so.1.0.19 \
-+ $(LIB)libgsm.so.1 \
-+ $(TOAST) $(TCAT) $(UNTOAST) \
- $(ROOT)/gsm-1.0.tar.Z
++ $(LIBGSMSO) $(LIB)/libgsm.so.${VER} \
++ $(LIB)libgsm.so.1 \
++ $(TOAST) $(TCAT) $(UNTOAST) \
+ $(ROOT)/gsm-1.0.tar.gz
diff --git a/libraries/gsm/patches/gsm-1.0.12-memcpy.patch b/libraries/gsm/gsm-1.0.12-memcpy.patch
index fc3c1ce232..fc3c1ce232 100644
--- a/libraries/gsm/patches/gsm-1.0.12-memcpy.patch
+++ b/libraries/gsm/gsm-1.0.12-memcpy.patch
diff --git a/libraries/gsm/gsm.SlackBuild b/libraries/gsm/gsm.SlackBuild
index 5ab252f713..b09b228790 100644
--- a/libraries/gsm/gsm.SlackBuild
+++ b/libraries/gsm/gsm.SlackBuild
@@ -30,11 +30,13 @@
# patched patch, removed rm error messages and fixed script as
# version labling in source is modified.
#note to self: update patching to sed or similar for next release.
+# 20220722 tim dickson: got rm patched added upstream. combined larger patch
+# into easier to maintain patch, and a few sed commands.
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=gsm
-VERSION=${VERSION:-1.0.19}
+VERSION=${VERSION:-1.0.20}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -87,13 +89,17 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \+
-# Patches ripped off from gentoo... (one is post updated by me)
-patch -p1 < $CWD/patches/gsm-1.0.19-shared.patch
-patch -p1 < $CWD/patches/gsm-1.0.12-memcpy.patch
-patch -p1 < $CWD/patches/gsm-1.0.12-64bit.patch
-#patch makefile to remove rm error messages
-sed -i '/^RMFLAGS/ c\RMFLAGS = -f' Makefile
-sed -i 's/-rm \$\@/-rm \$\(RMFLAGS\) \$\@/g' Makefile
+#the following patches are required but won't be fixed upstream due
+#to the fact that the library supports ancient 16bit processors
+#and he doesn't have all the hardware to test with any more.
+#"shared" patch (modified from a gentoo patch).
+patch < $CWD/Makefile.patch
+#next shouldn't be needed as config.h defines it (in inc/config.h)
+#patch -p1 < $CWD/patches/gsm-1.0.12-memcpy.patch
+#third patch has been replaced with a couple of sed's
+sed -i 's/typedef long/typedef int/g' inc/private.h
+sed -i 's/typedef unsigned long/typedef unsigned int/g' inc/private.h
+
mkdir -p $PKG/usr/bin
mkdir -p $PKG/usr/lib$LIBDIRSUFFIX
@@ -101,9 +107,10 @@ mkdir -p $PKG/usr/include/{gsm,libgsm}
mkdir -p $PKG/usr/man/man{1,3}
# Parallel builds are broken
-make CCINC="$SLKCFLAGS" -j1
+make CCINC="$SLKCFLAGS" VER="$VERSION" -j1
make -j1 install \
INSTALL_ROOT=$PKG/usr \
+ VER="$VERSION" \
GSM_INSTALL_LIB=$PKG/usr/lib$LIBDIRSUFFIX \
GSM_INSTALL_INC=$PKG/usr/include/gsm \
GSM_INSTALL_MAN=$PKG/usr/man/man3 \
diff --git a/libraries/gsm/gsm.info b/libraries/gsm/gsm.info
index 6f3ec7f342..be9a5a3944 100644
--- a/libraries/gsm/gsm.info
+++ b/libraries/gsm/gsm.info
@@ -1,8 +1,8 @@
PRGNAM="gsm"
-VERSION="1.0.19"
+VERSION="1.0.20"
HOMEPAGE="http://www.quut.com/gsm/"
-DOWNLOAD="http://www.quut.com/gsm/gsm-1.0.19.tar.gz"
-MD5SUM="36cca922928d68fa5fa53996c62f5854"
+DOWNLOAD="http://www.quut.com/gsm/gsm-1.0.20.tar.gz"
+MD5SUM="30d5bbe9d5c761ca0a58e7dd58099aae"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""
diff --git a/libraries/gsm/patches/gsm-1.0.12-64bit.patch b/libraries/gsm/patches/gsm-1.0.12-64bit.patch
deleted file mode 100644
index bc28c5099c..0000000000
--- a/libraries/gsm/patches/gsm-1.0.12-64bit.patch
+++ /dev/null
@@ -1,16 +0,0 @@
-diff -ur gsm-1.0-pl12.orig/inc/private.h gsm-1.0-pl12/inc/private.h
---- gsm-1.0-pl12.orig/inc/private.h 2006-04-26 22:17:01.000000000 +0300
-+++ gsm-1.0-pl12/inc/private.h 2007-08-19 12:23:02.000000000 +0300
-@@ -10,10 +10,10 @@
- #define PRIVATE_H
-
- typedef short word; /* 16 bit signed int */
--typedef long longword; /* 32 bit signed int */
-+typedef int longword; /* 32 bit signed int */
-
- typedef unsigned short uword; /* unsigned word */
--typedef unsigned long ulongword; /* unsigned longword */
-+typedef unsigned int ulongword; /* unsigned longword */
-
- struct gsm_state {
-