summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Barry J. Grundy2022-05-12 18:44:01 +0200
committer Willy Sudiarto Raharjo2022-05-14 14:27:59 +0200
commitf39578d5381b1afbe6eaeddd4813aeb3b9640d7d (patch)
tree13615dbc6cfedcd967c2036cd3a905cd20dcfbd6
parent9449edd729f284e37f63c049d4ae1d2477144828 (diff)
downloadslackbuilds-f39578d5381b1afbe6eaeddd4813aeb3b9640d7d.tar.gz
python/python2-yara: Added (Python2 for yara)
Signed-off-by: Dave Woodfall <dave@slackbuilds.org> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--python/python2-yara/README10
-rw-r--r--python/python2-yara/python2-yara.SlackBuild100
-rw-r--r--python/python2-yara/python2-yara.info10
-rw-r--r--python/python2-yara/slack-desc19
4 files changed, 139 insertions, 0 deletions
diff --git a/python/python2-yara/README b/python/python2-yara/README
new file mode 100644
index 0000000000..4ca9b14e48
--- /dev/null
+++ b/python/python2-yara/README
@@ -0,0 +1,10 @@
+python2-yara is a python2 library for YARA.
+
+YARA is a tool aimed at (but not limited to) helping malware researchers
+to identify and classify malware samples.
+
+With this library you can use YARA from your Python programs. It covers
+all YARA's features, from compiling, saving and loading rules to
+scanning files, strings and processes.
+
+python3-yara is available for use with python3.
diff --git a/python/python2-yara/python2-yara.SlackBuild b/python/python2-yara/python2-yara.SlackBuild
new file mode 100644
index 0000000000..eae13f956d
--- /dev/null
+++ b/python/python2-yara/python2-yara.SlackBuild
@@ -0,0 +1,100 @@
+#!/bin/bash
+
+# Slackware build script for yara-python
+# Copyright 2017-2022 Barry Grundy <bgrundy[at]linuxleo.com>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+#
+# updated (separate py2/3) - v4.2.0, May 2022, Barry J. Grundy.
+
+cd $(dirname $0) ; CWD=$(pwd)
+
+PRGNAM=python2-yara
+SRCNAM=yara-python
+VERSION=${VERSION:-4.2.0}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
+# the name of the created package would be, and then exit. This information
+# could be useful to other scripts.
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf "$SRCNAM"-$VERSION
+tar xvf $CWD/"$SRCNAM"-$VERSION.tar.gz
+cd "$SRCNAM"-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+export CC="gcc $SLKCFLAGS $(pkg-config --cflags talloc)"
+
+python2 setup.py build --dynamic-linking
+python2 setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a README.rst LICENSE $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/python/python2-yara/python2-yara.info b/python/python2-yara/python2-yara.info
new file mode 100644
index 0000000000..110eab0039
--- /dev/null
+++ b/python/python2-yara/python2-yara.info
@@ -0,0 +1,10 @@
+PRGNAM="python2-yara"
+VERSION="4.2.0"
+HOMEPAGE="https://github.com/VirusTotal/yara-python"
+DOWNLOAD="https://github.com/VirusTotal/yara-python/archive/v4.2.0/yara-python-4.2.0.tar.gz"
+MD5SUM="ea639d79070e9e95231af668a975f9de"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="yara"
+MAINTAINER="Barry J. Grundy"
+EMAIL="bgrundy<at>linuxleo.com"
diff --git a/python/python2-yara/slack-desc b/python/python2-yara/slack-desc
new file mode 100644
index 0000000000..294b8b090c
--- /dev/null
+++ b/python/python2-yara/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+python2-yara: python2-yara (Python2 for yara)
+python2-yara:
+python2-yara: yara-python is a Python library to allow the use of YARA directly
+python2-yara: in python programs. It covers all YARA's features, from compiling,
+python2-yara: saving and loading rules to scanning files, strings and
+python2-yara: processes.
+python2-yara:
+python2-yara: Homepage: https://github.com/VirusTotal/yara-python
+python2-yara:
+python2-yara:
+python2-yara: