summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author fourtysixandtwo2022-05-14 03:47:44 +0200
committer Willy Sudiarto Raharjo2022-05-14 14:27:50 +0200
commit5a863426ecff8d161ef712c471a5503e1b936b81 (patch)
tree4a4d7a5844b514dc2aa678ff0a77fbc6d7ee59fc
parentb68297eb37519897a5fae9760db3dbad5d2ce050 (diff)
downloadslackbuilds-5a863426ecff8d161ef712c471a5503e1b936b81.tar.gz
python/werkzeug-legacy1: Added (WSGI utility library for Python).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--python/werkzeug-legacy1/README24
-rw-r--r--python/werkzeug-legacy1/slack-desc19
-rw-r--r--python/werkzeug-legacy1/werkzeug-legacy1.SlackBuild96
-rw-r--r--python/werkzeug-legacy1/werkzeug-legacy1.info10
4 files changed, 149 insertions, 0 deletions
diff --git a/python/werkzeug-legacy1/README b/python/werkzeug-legacy1/README
new file mode 100644
index 0000000000..2e07764447
--- /dev/null
+++ b/python/werkzeug-legacy1/README
@@ -0,0 +1,24 @@
+The Swiss Army knife of Python web development
+
+Werkzeug started as simple collection of various utilities for WSGI
+applications and has become one of the most advanced WSGI utility
+modules. It includes a powerful debugger, full featured request and
+response objects, HTTP utilities to handle entity tags, cache control
+headers, HTTP dates, cookie handling, file uploads, a powerful URL
+routing system and a bunch of community contributed addon modules.
+
+Werkzeug is Unicode aware and doesn't enforce a specific template
+engine, database adapter or anything else. It doesn't even enforce
+a specific way of handling requests and leaves all that up to the
+developer.
+
+It's most useful for end user applications which should work on as
+many server environments as possible (such as blogs, wikis, bulletin
+boards, etc).
+
+NOTE:
+-This is a legacy version of werkzeug with python 2 and 3 support.
+
+IMPORTANT:
+-Conflicts with werkzeug and both cannot be installed at the same
+ time.
diff --git a/python/werkzeug-legacy1/slack-desc b/python/werkzeug-legacy1/slack-desc
new file mode 100644
index 0000000000..59b72f140b
--- /dev/null
+++ b/python/werkzeug-legacy1/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+werkzeug-legacy1: werkzeug-legacy1 (WSGI utility library for Python)
+werkzeug-legacy1:
+werkzeug-legacy1: Werkzeug started as simple collection of various utilities for WSGI
+werkzeug-legacy1: and has become one of the most advanced WSGI utility modules.
+werkzeug-legacy1: It includes a powerful debugger, fully featured request and response
+werkzeug-legacy1: objects, HTTP utilities to handle entity tags, cache control headers,
+werkzeug-legacy1: HTTP dates, cookie handling, file uploads, a powerful URL routing
+werkzeug-legacy1: system and a bunch of community contributed addon modules.
+werkzeug-legacy1:
+werkzeug-legacy1: Homepage: https://palletsprojects.com/p/werkzeug/
+werkzeug-legacy1:
diff --git a/python/werkzeug-legacy1/werkzeug-legacy1.SlackBuild b/python/werkzeug-legacy1/werkzeug-legacy1.SlackBuild
new file mode 100644
index 0000000000..7a03c5ed76
--- /dev/null
+++ b/python/werkzeug-legacy1/werkzeug-legacy1.SlackBuild
@@ -0,0 +1,96 @@
+#!/bin/bash
+
+# Slackware build script for werkzeug-legacy1
+
+# Copyright 2022 fourtysixandtwo <fourtysixandtwo@sliderr.net>
+# Copyright 2013 Mohamed LYAHYAOUI <mlyahyaoui@gmail.com>
+# Copyright 2018-2020 Dominik Drobek <dominik.drobek (at) o2.pl>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+cd $(dirname $0) ; CWD=$(pwd)
+
+PRGNAM=werkzeug-legacy1
+SRCNAM=Werkzeug
+VERSION=${VERSION:-1.0.1}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python2 setup.py install --root=$PKG
+python3 setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a CHANGES.rst LICENSE.rst PKG-INFO README.rst $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/python/werkzeug-legacy1/werkzeug-legacy1.info b/python/werkzeug-legacy1/werkzeug-legacy1.info
new file mode 100644
index 0000000000..c29951b645
--- /dev/null
+++ b/python/werkzeug-legacy1/werkzeug-legacy1.info
@@ -0,0 +1,10 @@
+PRGNAM="werkzeug-legacy1"
+VERSION="1.0.1"
+HOMEPAGE="https://palletsprojects.com/p/werkzeug/"
+DOWNLOAD="https://files.pythonhosted.org/packages/source/w/werkzeug/Werkzeug-1.0.1.tar.gz"
+MD5SUM="5d499cfdd30de5d9c946994783772efd"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="fourtysixandtwo"
+EMAIL="fourtysixandtwo@sliderr.net"