summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author fourtysixandtwo2022-05-04 14:17:31 +0200
committer Willy Sudiarto Raharjo2022-05-07 08:59:34 +0200
commit3da20816d07dbe4e928b7813b0fa04ba6575fee8 (patch)
tree411b6704f4faa7ddf21f770327822f479bd5b1c5
parentdcd58a1254135a850593cbf457abfa30914f0bb3 (diff)
downloadslackbuilds-3da20816d07dbe4e928b7813b0fa04ba6575fee8.tar.gz
python/python3-filetype: Added (file type and MIME type checking)
Signed-off-by: Dave Woodfall <dave@slackbuilds.org> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--python/python3-filetype/README6
-rw-r--r--python/python3-filetype/python3-filetype.SlackBuild99
-rw-r--r--python/python3-filetype/python3-filetype.info10
-rw-r--r--python/python3-filetype/slack-desc19
4 files changed, 134 insertions, 0 deletions
diff --git a/python/python3-filetype/README b/python/python3-filetype/README
new file mode 100644
index 0000000000..105e11ed73
--- /dev/null
+++ b/python/python3-filetype/README
@@ -0,0 +1,6 @@
+python3-filetype (infer file type and MIME type checking)
+
+Small and dependency free Python package to infer file type and MIME
+type checking the magic numbers signature of a file or buffer.
+
+This is a Python port from filetype Go package.
diff --git a/python/python3-filetype/python3-filetype.SlackBuild b/python/python3-filetype/python3-filetype.SlackBuild
new file mode 100644
index 0000000000..647a191b69
--- /dev/null
+++ b/python/python3-filetype/python3-filetype.SlackBuild
@@ -0,0 +1,99 @@
+#!/bin/bash
+
+# Slackware build script for python3-filetype
+
+# Copyright 2022 fourtysixandtwo <fourtysixandtwo@sliderr.net>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+cd $(dirname $0) ; CWD=$(pwd)
+
+PRGNAM=python3-filetype
+SRCNAM=$(echo $PRGNAM | sed 's/python3-//')
+VERSION=${VERSION:-1.0.13}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
+# the name of the created package would be, and then exit. This information
+# could be useful to other scripts.
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.?z
+cd $SRCNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+#fix setup.py as it tries to import from wrong library
+/usr/bin/sed -i 's/distutils.core/setuptools/' setup.py
+
+python3 setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a LICENSE README.rst $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/python/python3-filetype/python3-filetype.info b/python/python3-filetype/python3-filetype.info
new file mode 100644
index 0000000000..2ea4386ce0
--- /dev/null
+++ b/python/python3-filetype/python3-filetype.info
@@ -0,0 +1,10 @@
+PRGNAM="python3-filetype"
+VERSION="1.0.13"
+HOMEPAGE="https://github.com/h2non/filetype.py"
+DOWNLOAD="https://files.pythonhosted.org/packages/source/f/filetype/filetype-1.0.13.tar.gz"
+MD5SUM="d8d28ea2e68ebc70d91c2b3d71be96f3"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="fourtysixandtwo"
+EMAIL="fourtysixandtwo@sliderr.net"
diff --git a/python/python3-filetype/slack-desc b/python/python3-filetype/slack-desc
new file mode 100644
index 0000000000..62ee967167
--- /dev/null
+++ b/python/python3-filetype/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+python3-filetype: python3-filetype (infer file type and MIME type checking)
+python3-filetype:
+python3-filetype: Small and dependency free Python package to infer file type and MIME
+python3-filetype: type checking the magic numbers signature of a file or buffer.
+python3-filetype:
+python3-filetype: This is a Python port from filetype Go package.
+python3-filetype:
+python3-filetype: Homepage: https://github.com/h2non/filetype.py
+python3-filetype:
+python3-filetype:
+python3-filetype: