summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Barry J. Grundy2022-05-07 05:06:59 +0200
committer Willy Sudiarto Raharjo2022-05-07 08:59:36 +0200
commit0f35cd643b8c23a51d2248fe1b656d44e94847fc (patch)
tree3823c9c62a68c9435eb781af440d6ef9131b81cb
parent6ac863a7045b79663732f9f0e8fd90add2cadb6b (diff)
downloadslackbuilds-0f35cd643b8c23a51d2248fe1b656d44e94847fc.tar.gz
python/python2-distorm: Added (Disassembler Library)
Renamed from python/distorm. Signed-off-by: Dave Woodfall <dave@slackbuilds.org> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--python/python2-distorm/README9
-rw-r--r--python/python2-distorm/python2-distorm.SlackBuild97
-rw-r--r--python/python2-distorm/python2-distorm.info10
-rw-r--r--python/python2-distorm/slack-desc19
4 files changed, 135 insertions, 0 deletions
diff --git a/python/python2-distorm/README b/python/python2-distorm/README
new file mode 100644
index 0000000000..0d8c512a87
--- /dev/null
+++ b/python/python2-distorm/README
@@ -0,0 +1,9 @@
+python2-distorm (Disassembler Library for x86/AMD64 binary streams)
+
+diStorm is really a decomposer, which means it takes an
+instruction and returns a binary structure which describes
+it rather than static text, which is great for advanced
+binary code analysis.
+
+diStorm is super lightweight (~45KB), ultra fast and easy
+to use (a single API)!
diff --git a/python/python2-distorm/python2-distorm.SlackBuild b/python/python2-distorm/python2-distorm.SlackBuild
new file mode 100644
index 0000000000..95fa05a5b4
--- /dev/null
+++ b/python/python2-distorm/python2-distorm.SlackBuild
@@ -0,0 +1,97 @@
+#!/bin/bash
+
+# Slackware build script for python2-distorm
+# Copyright 2014-2022 Barry Grundy <bgrundy[at]linuxleo.com>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+#
+# Updated v3.5.2b May 2022 (and renamed to python2-distorm)
+
+cd $(dirname $0) ; CWD=$(pwd)
+
+PRGNAM=python2-distorm
+SRCNAM=distorm
+VERSION=${VERSION:-3.5.2b}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
+# the name of the created package would be, and then exit. This information
+# could be useful to other scripts.
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python2 setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a README.md $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/python/python2-distorm/python2-distorm.info b/python/python2-distorm/python2-distorm.info
new file mode 100644
index 0000000000..9b63e43fe2
--- /dev/null
+++ b/python/python2-distorm/python2-distorm.info
@@ -0,0 +1,10 @@
+PRGNAM="python2-distorm"
+VERSION="3.5.2b"
+HOMEPAGE="https://github.com/gdabah/distorm"
+DOWNLOAD="https://github.com/gdabah/distorm/archive/refs/tags/3.5.2b/distorm-3.5.2b.tar.gz"
+MD5SUM="9812e66e961e89269fdf6d3363973e6a"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Barry J. Grundy"
+EMAIL="bgrundy AT linuxleo.com"
diff --git a/python/python2-distorm/slack-desc b/python/python2-distorm/slack-desc
new file mode 100644
index 0000000000..a1f3efcfe9
--- /dev/null
+++ b/python/python2-distorm/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+python2-distorm: python2-distorm (Disassembler Library for x86/AMD64 binary streams)
+python2-distorm:
+python2-distorm: The goal of diStorm is to decode x86/AMD64 binary streams and return
+python2-distorm: a structure that describes each instruction.
+python2-distorm:
+python2-distorm:
+python2-distorm:
+python2-distorm:
+python2-distorm:
+python2-distorm:
+python2-distorm: