summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author fourtysixandtwo2022-05-04 07:15:17 +0200
committer Willy Sudiarto Raharjo2022-05-07 08:59:32 +0200
commit0dd2c1c129d01be788d41aa1efab89fd907ffe7a (patch)
treee0e4343ef2303bc2f2cb9d7f37f08397410f6650
parent007b77d3fab050cd141a5ab923edd4f994e9786e (diff)
downloadslackbuilds-0dd2c1c129d01be788d41aa1efab89fd907ffe7a.tar.gz
python/python3-rfc3986: Added (validation and authority parsing)
Signed-off-by: Dave Woodfall <dave@slackbuilds.org> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--python/python3-rfc3986/README5
-rw-r--r--python/python3-rfc3986/python3-rfc3986.SlackBuild99
-rw-r--r--python/python3-rfc3986/python3-rfc3986.info10
-rw-r--r--python/python3-rfc3986/slack-desc19
4 files changed, 133 insertions, 0 deletions
diff --git a/python/python3-rfc3986/README b/python/python3-rfc3986/README
new file mode 100644
index 0000000000..d303261571
--- /dev/null
+++ b/python/python3-rfc3986/README
@@ -0,0 +1,5 @@
+python3-rfc3986 (Python impl. incl. validation and authority parsing)
+
+A Python implementation of RFC 3986 including validation and authority
+parsing.
+
diff --git a/python/python3-rfc3986/python3-rfc3986.SlackBuild b/python/python3-rfc3986/python3-rfc3986.SlackBuild
new file mode 100644
index 0000000000..a1bf6d6a60
--- /dev/null
+++ b/python/python3-rfc3986/python3-rfc3986.SlackBuild
@@ -0,0 +1,99 @@
+#!/bin/bash
+
+# Slackware build script for python3-rfc3986
+
+# Copyright 2022 fourtysixandtwo <fourtysixandtwo@sliderr.net>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+cd $(dirname $0) ; CWD=$(pwd)
+
+PRGNAM=python3-rfc3986
+SRCNAM=$(echo $PRGNAM | sed 's/python3-//')
+VERSION=${VERSION:-2.0.0}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
+# the name of the created package would be, and then exit. This information
+# could be useful to other scripts.
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.?z
+cd $SRCNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+#fix setup.py as it tries to import from wrong library
+#/usr/bin/sed -i 's/distutils.core/setuptools/' setup.py
+
+python3 setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a LICENSE README.rst $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/python/python3-rfc3986/python3-rfc3986.info b/python/python3-rfc3986/python3-rfc3986.info
new file mode 100644
index 0000000000..72e6a983a4
--- /dev/null
+++ b/python/python3-rfc3986/python3-rfc3986.info
@@ -0,0 +1,10 @@
+PRGNAM="python3-rfc3986"
+VERSION="2.0.0"
+HOMEPAGE="https://github.com/python-hyper/rfc3986"
+DOWNLOAD="https://files.pythonhosted.org/packages/source/r/rfc3986/rfc3986-2.0.0.tar.gz"
+MD5SUM="bbf20302bf26bc771e88cc775fbde3bc"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="fourtysixandtwo"
+EMAIL="fourtysixandtwo@sliderr.net"
diff --git a/python/python3-rfc3986/slack-desc b/python/python3-rfc3986/slack-desc
new file mode 100644
index 0000000000..7e649caab9
--- /dev/null
+++ b/python/python3-rfc3986/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+python3-rfc3986: python3-rfc3986 (Python impl. incl. validation and authority parsing)
+python3-rfc3986:
+python3-rfc3986: A Python implementation of RFC 3986 including validation and authority
+python3-rfc3986: parsing.
+python3-rfc3986:
+python3-rfc3986:
+python3-rfc3986:
+python3-rfc3986:
+python3-rfc3986: Homepage: https://github.com/python-hyper/rfc3986
+python3-rfc3986:
+python3-rfc3986: