summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author klaatu2022-04-24 08:33:57 +0200
committer Willy Sudiarto Raharjo2022-04-30 08:52:04 +0200
commitf72032fc3b755528755d523a04dd97cf13edb801 (patch)
tree62a211c0ce7e3f84aec7e8dc9230603373cacde3
parent63ba647c7eaeba6eb0130ce578c088a108b01bcf (diff)
downloadslackbuilds-f72032fc3b755528755d523a04dd97cf13edb801.tar.gz
multimedia/MuseScore: build and README update
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--multimedia/MuseScore/MuseScore.SlackBuild39
-rw-r--r--multimedia/MuseScore/README3
2 files changed, 22 insertions, 20 deletions
diff --git a/multimedia/MuseScore/MuseScore.SlackBuild b/multimedia/MuseScore/MuseScore.SlackBuild
index 65e50c9670..2db14943c6 100644
--- a/multimedia/MuseScore/MuseScore.SlackBuild
+++ b/multimedia/MuseScore/MuseScore.SlackBuild
@@ -75,28 +75,31 @@ cp $CWD/MuseScore_General.sf3 share/sound
# so turn it off in CMakeLists.txt
sed -i '/(BUILD_CRASH_REPORTER/s|ON)|OFF)|' CMakeLists.txt
sed -i 's|share/man|man|' CMakeLists.txt
-#musescore doesn't like to build with webengine with qt4 installed
-#because the qmake finder finds the qt4 version. lets patch this
-sed -i 's/qmake)/qmake-qt5)/g' build/FindQt5.cmake
-
-make -j11 revision
-
-make -j11 release \
- PREFIX=/usr \
- CFLAGS="$SLKCFLAGS" \
- CXXFLAGS="$SLKCFLAGS" \
- LDFLAGS="-pthread" \
- MUSESCORE_BUILD_CONFIG=release \
- DOWNLOAD_SOUNDFONT=OFF \
- USE_SYSTEM_FREETYPE=ON \
- DBUILD_WEBENGINE=OFF \
- DBUILD_TELEMETRY_MODULE=OFF \
- VERBOSE=1
+
+mkdir b
+cd b
+cmake \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_C_FLAGS_RELEASE="$SLKCFLAGS" \
+ -DCMAKE_CXX_FLAGS_RELEASE="$SLKCFLAGS" \
+ -DCMAKE_MODULE_LINKER_FLAGS_RELEASE="-pthread" \
+ -DMUSESCORE_BUILD_CONFIG=release \
+ -DDOWNLOAD_SOUNDFONT=OFF \
+ -DUSE_SYSTEM_FREETYPE=ON \
+ -DBUILD_WEBENGINE=OFF \
+ -DBUILD_TELEMETRY_MODULE=OFF \
+ -DBUILD_PORTAUDIO=ON \
+ -DBUILD_PORTMIDI=ON \
+ -DQMAKE=/usr/lib"${LIBDIRSUFFIX}"/qt5/bin/qmake \
+ -DQT_QMAKE_EXECUTABLE=/usr/lib"${LIBDIRSUFFIX}"/qt5/bin/qmake \
+ ..
+
make install \
- -C build.release \
DESTDIR=$PKG \
UPDATE_CACHE=FALSE
+cd ..
+
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
diff --git a/multimedia/MuseScore/README b/multimedia/MuseScore/README
index 26c3e9a318..449a4c6663 100644
--- a/multimedia/MuseScore/README
+++ b/multimedia/MuseScore/README
@@ -6,6 +6,5 @@ program, licenced under GNU GPL. Features:
* easy and fast note entry with mouse, keyboard or midi
* integrated sequencer and FluidSynth software synthesizer
* import and export of MusicXml and standard midifiles (SMF)
- * platform independent code for Linux, Windows and Mac
+ * platform independent code for Linux, Windows, Mac
-Optional dependency: portaudio