summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Isaac Yu2022-04-30 04:35:49 +0200
committer Willy Sudiarto Raharjo2022-04-30 08:51:59 +0200
commit50beadcc0349f81db568e62c010e4802cad61761 (patch)
tree2445f7cafdc5bf8996ce8f813e5f0fd4cc84e2d9
parent8487626e66373ac10e9a1ea0d6ea00c5ba2f45b1 (diff)
downloadslackbuilds-50beadcc0349f81db568e62c010e4802cad61761.tar.gz
development/jupyterlab: Added (Jupyter next-gen user interface)
Signed-off-by: Dave Woodfall <dave@slackbuilds.org> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--development/jupyterlab/README9
-rw-r--r--development/jupyterlab/jupyterlab.SlackBuild102
-rw-r--r--development/jupyterlab/jupyterlab.info10
-rw-r--r--development/jupyterlab/no-nbclassic.patch15
-rw-r--r--development/jupyterlab/slack-desc19
5 files changed, 155 insertions, 0 deletions
diff --git a/development/jupyterlab/README b/development/jupyterlab/README
new file mode 100644
index 0000000000..f8918f06b1
--- /dev/null
+++ b/development/jupyterlab/README
@@ -0,0 +1,9 @@
+JupyterLab is the next-generation user interface for Project Jupyter
+offering all the familiar building blocks of the classic
+Jupyter Notebook (notebook, terminal, text editor, file browser,
+rich outputs, etc.) in a flexible and powerful user interface.
+JupyterLab will eventually replace the classic Jupyter Notebook.
+
+Jupyter kernels are needed for JupyterLab to be fully functional. The
+following kernels are currently available as SlackBuilds:
+* jupyter-ipykernel
diff --git a/development/jupyterlab/jupyterlab.SlackBuild b/development/jupyterlab/jupyterlab.SlackBuild
new file mode 100644
index 0000000000..e51fb7f06e
--- /dev/null
+++ b/development/jupyterlab/jupyterlab.SlackBuild
@@ -0,0 +1,102 @@
+#!/bin/bash
+
+# Slackware build script for jupyterlab
+
+# Copyright 2022 Isaac Yu <isaacyu1@isaacyu1.com>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+cd $(dirname $0) ; CWD=$(pwd)
+
+PRGNAM=jupyterlab
+VERSION=${VERSION:-3.3.4}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
+# the name of the created package would be, and then exit. This information
+# could be useful to other scripts.
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+# Remove nbclassic dependency
+sed -e '/nbclassic/d' -i setup.cfg
+patch -p1 < $CWD/no-nbclassic.patch
+
+# Fix /etc/jupyter path
+sed 's|etc|/etc|' -i setup.py
+
+python3 setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a CHANGELOG.md CONTRIBUTING.md CORPORATE.md README.md RELEASE.md LICENSE PKG-INFO $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/development/jupyterlab/jupyterlab.info b/development/jupyterlab/jupyterlab.info
new file mode 100644
index 0000000000..d40fdbb2cb
--- /dev/null
+++ b/development/jupyterlab/jupyterlab.info
@@ -0,0 +1,10 @@
+PRGNAM="jupyterlab"
+VERSION="3.3.4"
+HOMEPAGE="https://jupyter.org/"
+DOWNLOAD="https://files.pythonhosted.org/packages/source/j/jupyterlab/jupyterlab-3.3.4.tar.gz"
+MD5SUM="73363d46da921d0164ac4fbbbcdb00b5"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="jupyter-notebook_shim nodejs jupyterlab_server jupyter-ipykernel"
+MAINTAINER="Isaac Yu"
+EMAIL="isaacyu1@isaacyu1.com"
diff --git a/development/jupyterlab/no-nbclassic.patch b/development/jupyterlab/no-nbclassic.patch
new file mode 100644
index 0000000000..de63357340
--- /dev/null
+++ b/development/jupyterlab/no-nbclassic.patch
@@ -0,0 +1,15 @@
+This patch was taken from Arch Linux repositories:
+https://github.com/archlinux/svntogit-community/blob/packages/jupyterlab/trunk/no-nbclassic.patch
+diff --git a/jupyterlab/labapp.py b/jupyterlab/labapp.py
+index 1eb56b22fe..5a401a0fdf 100644
+--- a/jupyterlab/labapp.py
++++ b/jupyterlab/labapp.py
+@@ -19,7 +19,7 @@ from jupyterlab_server import (
+ WorkspaceImportApp,
+ WorkspaceListApp,
+ )
+-from nbclassic.shim import NBClassicConfigShimMixin
++from notebook_shim.shim import NotebookConfigShimMixin as NBClassicConfigShimMixin
+ from traitlets import Bool, Instance, Unicode, default
+
+ from ._version import __version__
diff --git a/development/jupyterlab/slack-desc b/development/jupyterlab/slack-desc
new file mode 100644
index 0000000000..20cce946a5
--- /dev/null
+++ b/development/jupyterlab/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+jupyterlab: jupyterlab (Jupyter next-generation user interface)
+jupyterlab:
+jupyterlab: JupyterLab is the next-generation user interface for Project Jupyter
+jupyterlab: offering all the familiar building blocks of the classic
+jupyterlab: Jupyter Notebook (notebook, terminal, text editor, file browser,
+jupyterlab: rich outputs, etc.) in a flexible and powerful user interface.
+jupyterlab: JupyterLab will eventually replace the classic Jupyter Notebook.
+jupyterlab:
+jupyterlab:
+jupyterlab:
+jupyterlab: