summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Tim Dickson2022-04-13 08:57:15 +0200
committer Willy Sudiarto Raharjo2022-04-16 07:12:42 +0200
commita271e183c7ef854b4ad4e54bd03ee5d24e8941bf (patch)
tree6ef7f527eeb59aa40af604279b2a61520d133213
parent88507b8b7af1a23e7b3945819d22681445ad731b (diff)
downloadslackbuilds-a271e183c7ef854b4ad4e54bd03ee5d24e8941bf.tar.gz
academic/sword: Updated for version 1.9.0.
Signed-off-by: Dave Woodfall <dave@slackbuilds.org> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--academic/sword/sword.SlackBuild12
-rw-r--r--academic/sword/sword.diff75
-rw-r--r--academic/sword/sword.info6
3 files changed, 7 insertions, 86 deletions
diff --git a/academic/sword/sword.SlackBuild b/academic/sword/sword.SlackBuild
index e8a80bd307..7ec9c9c693 100644
--- a/academic/sword/sword.SlackBuild
+++ b/academic/sword/sword.SlackBuild
@@ -27,7 +27,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=sword
-VERSION=${VERSION:-1.8.1}
+VERSION=${VERSION:-1.9.0}
BUILD=${BUILD:-3}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -74,9 +74,6 @@ cd $TMP
rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
-#patch to fix pre-chapter text, required for xiphos. when sword tag>1.8.1
-#remove this patch as it will be included.
-patch -p0 -i $CWD/$PRGNAM.diff
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
@@ -85,11 +82,10 @@ find -L . \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
#now patch the automake stuff so it doesn't error on slackware's newer version
-#thanks to aur.archlinux.org for the information...
-#since update to 1.8.1 first patch has to be commented out. we will get a bunch of
-#warnings, but at least the library compiles
-#sed -i 's/AM_INIT_AUTOMAKE$/AM_INIT_AUTOMAKE\(\[subdir\-objects\]\)/g' configure.ac
sed -i 's/ftemplate-depth-25/ftemplate-depth\=125/g' configure.ac
+#patch to remove subdir-objects warnings
+sed -i 's/1.6/1.6 subdir-objects/g' lib/Makefile.am
+
./autogen.sh
#add workaround for compiling with more recent (>=61) versions of icu4c
CFLAGS="$SLKCFLAGS -DU_USING_ICU_NAMESPACE=1" \
diff --git a/academic/sword/sword.diff b/academic/sword/sword.diff
deleted file mode 100644
index ac57df456c..0000000000
--- a/academic/sword/sword.diff
+++ /dev/null
@@ -1,75 +0,0 @@
-Index: src/mgr/stringmgr.cpp
-===================================================================
---- src/mgr/stringmgr.cpp (revision 3718)
-+++ src/mgr/stringmgr.cpp (revision 3721)
-@@ -20,6 +20,7 @@
- *
- */
-
-+#include <ctype.h>
- #include <stringmgr.h>
- #include <swlog.h>
- #include <localemgr.h>
-Index: src/modules/filters/osisxhtml.cpp
-===================================================================
---- src/modules/filters/osisxhtml.cpp (revision 3718)
-+++ src/modules/filters/osisxhtml.cpp (revision 3721)
-@@ -849,7 +849,11 @@
- else if (tag.isEndTag()) {
- outText("</div>", buf, u);
- }
-- else if (!(type == "colophon")) outText(tag, buf, u);
-+ else if (!(type == "colophon")) {
-+ if (tag.getAttribute("sID")) tag.setEmpty(false);
-+ if (tag.getAttribute("eID")) tag.setEndTag(true);
-+ outText(tag, buf, u);
-+ }
-
- }
- else if (!strcmp(tag.getName(), "span")) {
-Index: src/utilfuns/utilxml.cpp
-===================================================================
---- src/utilfuns/utilxml.cpp (revision 3718)
-+++ src/utilfuns/utilxml.cpp (revision 3721)
-@@ -291,13 +291,16 @@
- tag.append('/');
-
- tag.append(getName());
-- for (StringPairMap::iterator it = attributes.begin(); it != attributes.end(); it++) {
-- //tag.appendFormatted(" %s=\"%s\"", it->first.c_str(), it->second.c_str());
-- tag.append(' ');
-- tag.append(it->first.c_str());
-- tag.append((strchr(it->second.c_str(), '\"')) ? "=\'" : "=\"");
-- tag.append(it->second.c_str());
-- tag.append((strchr(it->second.c_str(), '\"'))? '\'' : '\"');
-+
-+ if (!isEndTag()) {
-+ for (StringPairMap::iterator it = attributes.begin(); it != attributes.end(); it++) {
-+ //tag.appendFormatted(" %s=\"%s\"", it->first.c_str(), it->second.c_str());
-+ tag.append(' ');
-+ tag.append(it->first.c_str());
-+ tag.append((strchr(it->second.c_str(), '\"')) ? "=\'" : "=\"");
-+ tag.append(it->second.c_str());
-+ tag.append((strchr(it->second.c_str(), '\"'))? '\'' : '\"');
-+ }
- }
-
- if (isEmpty())
-Index: include/utilxml.h
-===================================================================
---- include/utilxml.h (revision 3718)
-+++ include/utilxml.h (revision 3721)
-@@ -75,6 +75,13 @@
- * otherwise, we return if we're a simple XML end </tag>.
- */
- bool isEndTag(const char *eID = 0) const;
-+ inline void setEndTag(bool value) {
-+ if (!parsed)
-+ parse();
-+ endTag = value;
-+ if (value)
-+ empty = false;
-+ }
-
- const StringList getAttributeNames() const;
- int getAttributePartCount(const char *attribName, char partSplit = '|') const;
diff --git a/academic/sword/sword.info b/academic/sword/sword.info
index bafb795e6c..8417f0c7ec 100644
--- a/academic/sword/sword.info
+++ b/academic/sword/sword.info
@@ -1,8 +1,8 @@
PRGNAM="sword"
-VERSION="1.8.1"
+VERSION="1.9.0"
HOMEPAGE="http://www.crosswire.org/sword"
-DOWNLOAD="http://crosswire.org/ftpmirror/pub/sword/source/v1.8/sword-1.8.1.tar.gz"
-MD5SUM="ddab24192104b15cbec72e569145ccd1"
+DOWNLOAD="http://crosswire.org/ftpmirror/pub/sword/source/v1.9/sword-1.9.0.tar.gz"
+MD5SUM="7b86ab627993ef295307e3729d8edef2"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""