summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Andrew Clemons2021-10-24 12:39:32 +0200
committer Willy Sudiarto Raharjo2021-10-27 03:40:38 +0200
commit9169ef1fe100dd5c30f70ee17f6e3d031dc86215 (patch)
treeb54b6578ff40593bbdef5aa3dac74f350e23defb
parentf5b66201e1ae3d52e4d98de084ad7081a6ea689e (diff)
downloadslackbuilds-9169ef1fe100dd5c30f70ee17f6e3d031dc86215.tar.gz
python/reedsolo: Fix building with gcc on -current.
Signed-off-by: Andrew Clemons <andrew.clemons@gmail.com> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--python/reedsolo/reedsolo.SlackBuild5
1 files changed, 4 insertions, 1 deletions
diff --git a/python/reedsolo/reedsolo.SlackBuild b/python/reedsolo/reedsolo.SlackBuild
index f50e111497..76669f0959 100644
--- a/python/reedsolo/reedsolo.SlackBuild
+++ b/python/reedsolo/reedsolo.SlackBuild
@@ -65,15 +65,18 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+rm -f creedsolo.c
+
# Python 2.7 will be droped in the future.
if $(python2 -c 'import sys' 2>/dev/null); then
python2 setup.py install --root=$PKG
- else
+else
python setup.py install --root=$PKG
fi
# Replacement of python-2.x Python3.x check presence and build if found.
if $(python3 -c 'import sys' 2>/dev/null); then
+ rm -f creedsolo.c
python3 setup.py install --root=$PKG
fi