summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Arn02022-03-14 13:51:50 +0100
committer Willy Sudiarto Raharjo2022-03-17 18:26:04 +0100
commita19824abe9807680be3a3b75da92078072dddebb (patch)
tree08aa1a09e8900cc41cb16f9bd2042c3d0f1d323c
parentf71a52af959131d7ed96fd5324c70f9e50b429f8 (diff)
downloadslackbuilds-a19824abe9807680be3a3b75da92078072dddebb.tar.gz
python/WebHelpers: Removed, replaced by WebHelpers2 on python3-webhelpers2
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--python/WebHelpers/README16
-rw-r--r--python/WebHelpers/WebHelpers.SlackBuild77
-rw-r--r--python/WebHelpers/WebHelpers.info10
-rw-r--r--python/WebHelpers/slack-desc19
4 files changed, 0 insertions, 122 deletions
diff --git a/python/WebHelpers/README b/python/WebHelpers/README
deleted file mode 100644
index 79cc2a8b40..0000000000
--- a/python/WebHelpers/README
+++ /dev/null
@@ -1,16 +0,0 @@
-WebHelpers is a wide variety of utility functions for web applications
-and other applications.
-It can be used with any web framework.
-
-WebHelpers includes the widely-used HTML tag builder with smart escaping
-and convenience functions for common tags such as form fields.
-The common builder ensures the tags are syntactically correct and
-prevent cross-site scripting attacks and double-escaping.
-
-Other helpers perform text processing, split a large number of records
-into pages, generate Atom/RSS feeds with geographical (GIS) data, handle
-MIME types, calculate numerica statistics, and more.
-There are also high-level container types, including a value counter and
-accumulator.
-There are lists of country names, country codes, US states, Canadian
-provinces, and UK counties.
diff --git a/python/WebHelpers/WebHelpers.SlackBuild b/python/WebHelpers/WebHelpers.SlackBuild
deleted file mode 100644
index da8cc3faaf..0000000000
--- a/python/WebHelpers/WebHelpers.SlackBuild
+++ /dev/null
@@ -1,77 +0,0 @@
-#!/bin/bash
-
-# SlackBuild script for WebHelpers.
-# Yth | Pont-en-Royans, France | yth@ythogtha.org
-
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-cd $(dirname $0) ; CWD=$(pwd)
-
-PRGNAM=WebHelpers
-VERSION=${VERSION:-1.3}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-PKGTYPE=${PKGTYPE:-tgz}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
-if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
- echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
- exit 0
-fi
-
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-python2 setup.py install --root=$PKG
-python3 setup.py install --root=$PKG
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a README* MANIFEST.in $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/python/WebHelpers/WebHelpers.info b/python/WebHelpers/WebHelpers.info
deleted file mode 100644
index da3ddbda24..0000000000
--- a/python/WebHelpers/WebHelpers.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="WebHelpers"
-VERSION="1.3"
-HOMEPAGE="https://webhelpers.readthedocs.org/en/latest/"
-DOWNLOAD="https://pypi.python.org/packages/source/W/WebHelpers/WebHelpers-1.3.tar.gz"
-MD5SUM="32749ffadfc40fea51075a7def32588b"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES="python2-MarkupSafe"
-MAINTAINER="Yth - Arnaud"
-EMAIL="yth@ythogtha.org"
diff --git a/python/WebHelpers/slack-desc b/python/WebHelpers/slack-desc
deleted file mode 100644
index 2d78bd5859..0000000000
--- a/python/WebHelpers/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-WebHelpers: WebHelpers (utility functions)
-WebHelpers:
-WebHelpers: WebHelpers is a wide variety of utility functions for web
-WebHelpers: applications and other applications.
-WebHelpers: It can be used with any web framework.
-WebHelpers:
-WebHelpers:
-WebHelpers:
-WebHelpers:
-WebHelpers:
-WebHelpers: