summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author B. Watson2022-03-09 21:21:18 +0100
committer B. Watson2022-03-09 21:21:18 +0100
commitff183534a93c0382b1dbb4f314d9d907bd23cfa7 (patch)
tree1a8683a8c6cc81ca674a2c8344376a8e0cb45bc2
parent4be37caca7abec7c72ba9c4b4d2b1b3d2747a0d5 (diff)
downloadslackbuilds-ff183534a93c0382b1dbb4f314d9d907bd23cfa7.tar.gz
system/sysdig: Use correct github URL.
Signed-off-by: B. Watson <yalhcru@gmail.com>
-rw-r--r--system/sysdig/sysdig.SlackBuild12
-rw-r--r--system/sysdig/sysdig.info2
2 files changed, 7 insertions, 7 deletions
diff --git a/system/sysdig/sysdig.SlackBuild b/system/sysdig/sysdig.SlackBuild
index e95098c272..bb0d7af4b4 100644
--- a/system/sysdig/sysdig.SlackBuild
+++ b/system/sysdig/sysdig.SlackBuild
@@ -41,9 +41,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$PKGVER-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -76,15 +73,18 @@ rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
+FALCO_HASH=${FALCO_HASH:-2160111cd088aea9ae2235d3385ecb0b1ab6623c}
+
mkdir -p build/falcosecurity-libs-repo/falcosecurity-libs-prefix/src
-cp $CWD/2160111cd088aea9ae2235d3385ecb0b1ab6623c.tar.gz build/falcosecurity-libs-repo/falcosecurity-libs-prefix/src/
+cp $CWD/libs-$FALCO_HASH.tar.gz \
+ build/falcosecurity-libs-repo/falcosecurity-libs-prefix/src/$FALCO_HASH.tar.gz
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
+ -o -perm 511 \) -exec chmod 755 {} \+ -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \+
# Fix manpage location
sed -i 's|share/||' userspace/sysdig/man/CMakeLists.txt
diff --git a/system/sysdig/sysdig.info b/system/sysdig/sysdig.info
index d034a60cc2..37455a58ca 100644
--- a/system/sysdig/sysdig.info
+++ b/system/sysdig/sysdig.info
@@ -2,7 +2,7 @@ PRGNAM="sysdig"
VERSION="0.28.0"
HOMEPAGE="https://www.sysdig.org"
DOWNLOAD="https://github.com/draios/sysdig/archive/0.28.0/sysdig-0.28.0.tar.gz \
- https://github.com/falcosecurity/libs/archive/2160111cd088aea9ae2235d3385ecb0b1ab6623c.tar.gz"
+ https://github.com/falcosecurity/libs/archive/2160111/libs-2160111cd088aea9ae2235d3385ecb0b1ab6623c.tar.gz"
MD5SUM="b0a25f902d6d520380f03a1f39177033 \
52ff63dc35604d0a37aa780a4472a114"
DOWNLOAD_x86_64=""