summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Isaac Yu2022-03-09 21:40:47 +0100
committer Willy Sudiarto Raharjo2022-03-10 04:41:29 +0100
commiteb05ff6fd8ab20b62209905f49099e0e7444415d (patch)
treef83624e5991c7637a06d5a29db2c7291e2433deb
parent13afcbf176d7e6b5a2d9674ad946e2de83a5f599 (diff)
downloadslackbuilds-eb05ff6fd8ab20b62209905f49099e0e7444415d.tar.gz
python/BeautifulSoup4: Update for 4.10.0
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--python/BeautifulSoup4/BeautifulSoup4.SlackBuild33
-rw-r--r--python/BeautifulSoup4/BeautifulSoup4.info8
-rw-r--r--python/BeautifulSoup4/README3
3 files changed, 12 insertions, 32 deletions
diff --git a/python/BeautifulSoup4/BeautifulSoup4.SlackBuild b/python/BeautifulSoup4/BeautifulSoup4.SlackBuild
index 74338d9973..c47c5ef2ad 100644
--- a/python/BeautifulSoup4/BeautifulSoup4.SlackBuild
+++ b/python/BeautifulSoup4/BeautifulSoup4.SlackBuild
@@ -3,7 +3,7 @@
# Slackware build script for BeautifulSoup4
# Copyright 2014-2018 Dimitris Zlatanidis Orestiada, Greece
-# Copyright 2020-2021 Isaac Yu <isaacyu1@isaacyu1.com>
+# Copyright 2020-2022 Isaac Yu <isaacyu1@isaacyu1.com>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -26,8 +26,8 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=BeautifulSoup4
-VERSION=${VERSION:-4.9.3}
-BUILD=${BUILD:-2}
+VERSION=${VERSION:-4.10.0}
+BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -82,36 +82,13 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python2 setup.py install --root=$PKG
-
-# Python 3 support (requires python3-soupsieve)
-# shaypal5 provided an example package check:
-# https://gist.github.com/shaypal5/d505af9953cd86f59c750fa600ee4ba6
-if $(python3 -c 'import pkgutil; exit(not pkgutil.find_loader("soupsieve"))'); then
-
- # Prepare another source tarball before building for Python 3
- cd $TMP
- rm -rf $SRCNAM-$VERSION
- tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
- cd $SRCNAM-$VERSION
- chown -R root:root .
- find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
- # Build for Python 3
- sed -i "s/-rfI/-rf/" convert-py3k
- sh convert-py3k
- python3 setup.py install --root=$PKG
-fi
+python3 setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a README.md COPYING.txt NEWS.txt TODO.txt doc/* $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a README.md COPYING.txt LICENSE NEWS.txt TODO.txt doc/* $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
diff --git a/python/BeautifulSoup4/BeautifulSoup4.info b/python/BeautifulSoup4/BeautifulSoup4.info
index 7203506282..4093fcabeb 100644
--- a/python/BeautifulSoup4/BeautifulSoup4.info
+++ b/python/BeautifulSoup4/BeautifulSoup4.info
@@ -1,10 +1,10 @@
PRGNAM="BeautifulSoup4"
-VERSION="4.9.3"
+VERSION="4.10.0"
HOMEPAGE="https://www.crummy.com/software/BeautifulSoup/"
-DOWNLOAD="https://www.crummy.com/software/BeautifulSoup/bs4/download/4.9/beautifulsoup4-4.9.3.tar.gz"
-MD5SUM="57fd468ae3eb055f6871106e8f7813e2"
+DOWNLOAD="https://files.pythonhosted.org/packages/a1/69/daeee6d8f22c997e522cdbeb59641c4d31ab120aba0f2c799500f7456b7e/beautifulsoup4-4.10.0.tar.gz"
+MD5SUM="e754242642253dd31d249d00358d552e"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES="python2-soupsieve python3-soupsieve"
+REQUIRES="python3-soupsieve"
MAINTAINER="Isaac Yu"
EMAIL="isaacyu1@isaacyu1.com"
diff --git a/python/BeautifulSoup4/README b/python/BeautifulSoup4/README
index bcbf3677fa..adabd10335 100644
--- a/python/BeautifulSoup4/README
+++ b/python/BeautifulSoup4/README
@@ -1,3 +1,6 @@
Beautiful Soup is a Python HTML/XML parser designed for quick
turnaround projects like screen-scraping. It commonly saves
programmers hours or days of work.
+
+Beautiful Soup >= 4.10.0 has dropped Python 2 support. The
+python2-BeautifulSoup4 SlackBuild is available at version 4.9.3.