summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Pouria Rezaei2021-04-02 20:09:16 +0200
committer Willy Sudiarto Raharjo2021-04-03 03:48:32 +0200
commit5526cf82a84de3c7aee7f638ec6ccbbad3d4ddbb (patch)
tree18cf077507f80305b607916ca94f78f852e1e801
parent47afa1c668155ad1cde42bc217ecd65ee8a3885d (diff)
downloadslackbuilds-5526cf82a84de3c7aee7f638ec6ccbbad3d4ddbb.tar.gz
python/python3-stagger: Added (Stagger Python3 library)
Signed-off-by: Dave Woodfall <dave@slackbuilds.org> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--python/python3-stagger/README10
-rw-r--r--python/python3-stagger/python3-stagger.SlackBuild92
-rw-r--r--python/python3-stagger/python3-stagger.info10
-rw-r--r--python/python3-stagger/slack-desc19
4 files changed, 131 insertions, 0 deletions
diff --git a/python/python3-stagger/README b/python/python3-stagger/README
new file mode 100644
index 0000000000..74ad8ab11b
--- /dev/null
+++ b/python/python3-stagger/README
@@ -0,0 +1,10 @@
+The ID3v2 tag format is notorious for its useless specification
+documents and its quirky, mutually incompatible part-implementations.
+Stagger is to provide a robust tagging package that is able to handle
+all the various badly formatted tags out there and allow you to convert
+them to a consensus format.
+*If you ran into source not found and can't be extracted, make sure it
+starts with release* not the stagger-release*, it's probably because
+you've downloaded from github directly via browser.
+
+By ~red
diff --git a/python/python3-stagger/python3-stagger.SlackBuild b/python/python3-stagger/python3-stagger.SlackBuild
new file mode 100644
index 0000000000..f1a6810196
--- /dev/null
+++ b/python/python3-stagger/python3-stagger.SlackBuild
@@ -0,0 +1,92 @@
+#!/bin/sh
+
+# Slackware build script for python3-stagger
+
+# Copyright 2019-2020 Pouria Rezaei <Pouria.rz@outlook.com>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+
+PRGNAM=python3-stagger
+SRCNAM=stagger
+VERSION=${VERSION:-1.0.1}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCNAM-release-$VERSION
+tar xvf $CWD/release-$VERSION.tar.gz
+cd $SRCNAM-release-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+sed -i -e "s~.*scripts=glob.glob(\"Scripts/\*.py\"),~~" setup.py
+
+python3 setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" \
+ | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+PRGDOC=$PKG/usr/doc/$PRGNAM-$VERSION
+
+# Install documentation.
+mkdir -p $PRGDOC
+cat $CWD/README > $PRGDOC/README
+cat $CWD/$PRGNAM.SlackBuild > $PRGDOC/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/python3-stagger/python3-stagger.info b/python/python3-stagger/python3-stagger.info
new file mode 100644
index 0000000000..220995aac7
--- /dev/null
+++ b/python/python3-stagger/python3-stagger.info
@@ -0,0 +1,10 @@
+PRGNAM="python3-stagger"
+VERSION="1.0.1"
+HOMEPAGE="http://github.com/lorentey/stagger"
+DOWNLOAD="https://github.com/staggerpkg/stagger/archive/refs/tags/release-1.0.1.tar.gz"
+MD5SUM="b4b141bc36cfda0d6f9b2d40cff3b346"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="python3"
+MAINTAINER="Pouria Rezaei"
+EMAIL="Pouria.rz@outlook.com"
diff --git a/python/python3-stagger/slack-desc b/python/python3-stagger/slack-desc
new file mode 100644
index 0000000000..98636f91c0
--- /dev/null
+++ b/python/python3-stagger/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+python3-stagger: python3-stagger (Stagger Python3 library)
+python3-stagger:
+python3-stagger: The ID3v2 tag format is notorious for its useless specification
+python3-stagger: documents and its quirky, mutually incompatible part-implementations.
+python3-stagger: Stagger is to provide a robust tagging package that is able to
+python3-stagger: handle all the various badly formatted tags out there and allow you
+python3-stagger: to convert them to a consensus format.
+python3-stagger:
+python3-stagger:
+python3-stagger:
+python3-stagger: Homepage: https://pypi.org/project/stagger/