summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Pr. HORSTMANN2021-01-02 04:19:21 +0100
committer Willy Sudiarto Raharjo2021-01-02 04:48:19 +0100
commite806cf68765f5e82e527c40e152f120f7a96b698 (patch)
tree37ae0101ed549dc66534e9853e84d05bca4e8ff4
parente6226dfb494d5982666d04da0faaef92ea83349c (diff)
downloadslackbuilds-e806cf68765f5e82e527c40e152f120f7a96b698.tar.gz
python/pyblake2: Added (BLAKE2 hash function extension module).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--python/pyblake2/README1
-rw-r--r--python/pyblake2/pyblake2.SlackBuild89
-rw-r--r--python/pyblake2/pyblake2.info10
-rw-r--r--python/pyblake2/slack-desc19
4 files changed, 119 insertions, 0 deletions
diff --git a/python/pyblake2/README b/python/pyblake2/README
new file mode 100644
index 0000000000..adf197ca1d
--- /dev/null
+++ b/python/pyblake2/README
@@ -0,0 +1 @@
+BLAKE2 hash function extension module
diff --git a/python/pyblake2/pyblake2.SlackBuild b/python/pyblake2/pyblake2.SlackBuild
new file mode 100644
index 0000000000..34130d56ac
--- /dev/null
+++ b/python/pyblake2/pyblake2.SlackBuild
@@ -0,0 +1,89 @@
+#!/bin/sh
+# SlackBuild script for pyblake2
+
+# Copyright (c) 2000-2011 Pr. Horstmann <wmh (at) eipg.fr>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=pyblake2
+VERSION=${VERSION:-1.1.2}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+CWD=$(pwd)
+TMP=${TMP:-/tmp}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+if [ "$ARCH" = "i586" ]; then
+ MOSCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ MOSCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ MOSCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ MOSCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+set -e
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+ # Python 2.7 will be droped in the future.
+if $(python2 -c 'import sys' 2>/dev/null); then
+ python2 setup.py install --root=$PKG
+ else
+ python setup.py install --root=$PKG
+fi
+
+# Replacement of python-2.x Python3.x check presence and build if found.
+if $(python3 -c 'import sys' 2>/dev/null); then
+ python3 setup.py install --root=$PKG
+fi
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/pyblake2/pyblake2.info b/python/pyblake2/pyblake2.info
new file mode 100644
index 0000000000..88aff82810
--- /dev/null
+++ b/python/pyblake2/pyblake2.info
@@ -0,0 +1,10 @@
+PRGNAM="pyblake2"
+VERSION="1.1.2"
+HOMEPAGE="https://pypi.org/project/pyblake2/"
+DOWNLOAD="https://files.pythonhosted.org/packages/a6/ea/559658f48713567276cabe1344a9ef918adcb34a9da417dbf0a2f7477d8e/pyblake2-1.1.2.tar.gz"
+MD5SUM="d2306b67d17274bca06d598b64ef7b38"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Pr. HORSTMANN"
+EMAIL="wmh@eipg.fr"
diff --git a/python/pyblake2/slack-desc b/python/pyblake2/slack-desc
new file mode 100644
index 0000000000..bb2ae2f84a
--- /dev/null
+++ b/python/pyblake2/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+pyblake2: pyblake2 (BLAKE2 hash function extension module)
+pyblake2:
+pyblake2: pyblake2 is an extension module for Python implementing BLAKE2 hash
+pyblake2: function.
+pyblake2:
+pyblake2: BLAKE2 is a cryptographic hash function, which offers highest
+pyblake2: security while being as fast as MD5 or SHA-1, and comes in two
+pyblake2: flavors.
+pyblake2:
+pyblake2: Homepage: https://pypi.org/project/pyblake2/
+pyblake2: