summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Pr. HORSTMANN2021-01-02 04:37:53 +0100
committer Willy Sudiarto Raharjo2021-01-02 04:48:21 +0100
commit34b4592c73549ddc14db53c8047185dfdfe2e238 (patch)
tree9a731700ce629611ed29ff8a5e20664c900dc5bc
parentb8fd1b18b7f5a4b6a5666dd56c4bcd34f276a635 (diff)
downloadslackbuilds-34b4592c73549ddc14db53c8047185dfdfe2e238.tar.gz
python/hachoir: Added (library to view and edit binary stream).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--python/hachoir/README3
-rw-r--r--python/hachoir/hachoir.SlackBuild89
-rw-r--r--python/hachoir/hachoir.info10
-rw-r--r--python/hachoir/slack-desc19
4 files changed, 121 insertions, 0 deletions
diff --git a/python/hachoir/README b/python/hachoir/README
new file mode 100644
index 0000000000..bec701234a
--- /dev/null
+++ b/python/hachoir/README
@@ -0,0 +1,3 @@
+Hachoir is a Python library to view and edit a binary stream field by field.
+In other words, Hachoir allows you to browse any binary stream just like you
+browse directories and files.
diff --git a/python/hachoir/hachoir.SlackBuild b/python/hachoir/hachoir.SlackBuild
new file mode 100644
index 0000000000..186b3e1777
--- /dev/null
+++ b/python/hachoir/hachoir.SlackBuild
@@ -0,0 +1,89 @@
+#!/bin/sh
+# SlackBuild script for hachoir
+# Copyright (c) 2000-2021 Pr. Horstmann <wmh (at) eipg.fr>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+#
+PRGNAM=hachoir
+VERSION=${VERSION:-3.1.1}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+CWD=$(pwd)
+TMP=${TMP:-/tmp}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+# Python 2.7 will be droped in the future.
+if $(python2 -c 'import sys' 2>/dev/null); then
+ python2 setup.py install --root=$PKG
+ else
+ python setup.py install --root=$PKG
+fi
+
+# Replacement of python-2.x Python3.x check presence and build if found.
+if $(python3 -c 'import sys' 2>/dev/null); then
+ python3 setup.py install --root=$PKG
+fi
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/hachoir/hachoir.info b/python/hachoir/hachoir.info
new file mode 100644
index 0000000000..d4c93b0dc1
--- /dev/null
+++ b/python/hachoir/hachoir.info
@@ -0,0 +1,10 @@
+PRGNAM="hachoir"
+VERSION="3.1.1"
+HOMEPAGE="https://pypi.python.org/pypi/hachoir"
+DOWNLOAD="https://files.pythonhosted.org/packages/a9/27/cec720492aba5f45161e0dd91213337a3e1f8c700f4e486f41b1d01d0552/hachoir-3.1.1.tar.gz"
+MD5SUM="880ee1744ccabb90b7e4863e95efa143"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Pr. HORSTMANN"
+EMAIL="wmh@eipg.fr"
diff --git a/python/hachoir/slack-desc b/python/hachoir/slack-desc
new file mode 100644
index 0000000000..0a91b69423
--- /dev/null
+++ b/python/hachoir/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+hachoir: hachoir (library to view and edit binary stream field by field)
+hachoir:
+hachoir: A file is splitted in tree of fields, where smallest field is one bit.
+hachoir: Ex: fields types: integers, strings, bits, padding types, floats, etc.
+hachoir:
+hachoir: hachoir-grep: find a text pattern in a binary file
+hachoir: hachoir-metadata: get metadata from binary files
+hachoir: hachoir-strip: modify a file to remove metadata
+hachoir: hachoir-urwid: display the content of a binary file in text mode
+hachoir:
+hachoir: Homepage: https://pypi.python.org/pypi/hachoir