summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Lenard Spencer2021-01-02 00:30:10 +0100
committer Willy Sudiarto Raharjo2021-01-02 04:48:27 +0100
commit191138093143bd9eb56b23969e6f0be4ab7c7427 (patch)
tree153ff2bf177a162a326aa78da6bff0be67e9f75b
parent328589fbb621d2600db5be73bfa55c94566dada8 (diff)
downloadslackbuilds-191138093143bd9eb56b23969e6f0be4ab7c7427.tar.gz
multimedia/lives: Various script fixes.
Signed-off-by: Dave Woodfall <dave@slackbuilds.org> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--multimedia/lives/README15
-rw-r--r--multimedia/lives/lives.SlackBuild39
-rw-r--r--multimedia/lives/slack-desc8
3 files changed, 42 insertions, 20 deletions
diff --git a/multimedia/lives/README b/multimedia/lives/README
index a0296a8354..8772d9807b 100644
--- a/multimedia/lives/README
+++ b/multimedia/lives/README
@@ -20,10 +20,23 @@ performances, and as a video editor is capable of creating dazzling
clips in a huge variety of formats.
Optional dependencies:
-ffmpeg mjpegtools ladspa_sdk libunicap libdv schroedinger frei0r libavc1394
+ffmpeg mjpegtools ladspa_sdk libunicap libdv schroedinger frei0r
+ libavc1394 opencv (or opencv-legacy - If opencv-legacy is installed,
+ the toonz plugin will not be built.)
+
+
+If after initialization the program does not properly come up on the
+screen, right-click on the entry in the taskbar, then go to
+'More Actions -> Resize', then click anywhere on the screen and it
+should lock in.
+
+NOTE! You must remove any previous installation of lives before
+running this script or the build will fail.
This package uses POSIX filesystem capabilities to execute with
elevated privileges (required for realtime audio processing). This
may be considered a security/stability risk. Please read
http://www.slackbuilds.org/caps/ for more information. To disable
capabilities, pass SETCAP=no to the script.
+
+Version 3.0.2 will be the last for Slackware 14.2.
diff --git a/multimedia/lives/lives.SlackBuild b/multimedia/lives/lives.SlackBuild
index c99f6006ed..c224ef53ef 100644
--- a/multimedia/lives/lives.SlackBuild
+++ b/multimedia/lives/lives.SlackBuild
@@ -4,7 +4,7 @@
# Copyright 2014-2015 Yanes Checcacci Balod <yanes@pobox.com>, Brazil
# Copyright 2015-2016 Marcel Saegebarth <marc@mos6581.de>
-# Copyright 2020 Lenard Spencer <lenardrspencer@gmail.com>
+# Copyright 2020 Lenard Spencer, Orlando,Florida, USA
# All rights reserved.
#
# Redistribution and use in source and binary forms, with or without
@@ -29,7 +29,7 @@
PRGNAM=lives
SRCNAM=LiVES
VERSION=${VERSION:-3.0.2}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@@ -59,11 +59,17 @@ else
LIBDIRSUFFIX=""
fi
+# Check for a previous LiVES installation:
+if [ -e /usr/bin/lives ]; then
+ echo "ERROR: A previous LiVES installation is detected!"
+ echo "Please remove it before running this script."
+ exit 1
+fi
+
set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
-
cd $TMP
rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$SRCNAM-$VERSION.tar.bz2
@@ -75,14 +81,16 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-# Don't build toonz plugin (build failure when opencv is present)
-# https://sourceforge.net/p/lives/bugs/217/
-sed -i -e '/toonz/d' lives-plugins/weed-plugins/Makefile.am
-autoreconf -fi
-automake
+# Don't build toonz plugin if opencv-legacy is found (breaks build)
+# (opencv 4.x reports as opencv4):
+if [ pkg-config --exists opencv ]; then
+ sed -i -e '/toonz/d' lives-plugins/weed-plugins/Makefile.am
+ autoreconf -fiv
+ automake
+fi
CFLAGS="$SLKCFLAGS" \
-CXXFLAGS="$SLKCFLAGS" \
+CXXFLAGS="$SLKCFLAGS -std=c++11" \
./configure \
--prefix=/usr \
--libdir=/usr/lib${LIBDIRSUFFIX} \
@@ -92,16 +100,17 @@ CXXFLAGS="$SLKCFLAGS" \
--docdir=/usr/doc/$PRGNAM-$VERSION \
--build=$ARCH-slackware-linux
-# Parallel builds break, so we make sure MAKEFLAGS is clear:
-unset MAKEFLAGS
-make
-make install-strip DESTDIR=$PKG
+make -j1 # Parallel builds have a tendency to fail
+make install DESTDIR=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a \
- ABOUT-NLS AUTHORS COPYING* ChangeLog FEATURES GETTING.STARTED INSTALL \
+ ABOUT-NLS AUTHORS COPYING ChangeLog FEATURES GETTING.STARTED INSTALL \
NEWS README \
- $PKG/usr/doc/$PRGNAM-$VERSION || true
+ $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
(
diff --git a/multimedia/lives/slack-desc b/multimedia/lives/slack-desc
index f156f9040e..00576dd9d0 100644
--- a/multimedia/lives/slack-desc
+++ b/multimedia/lives/slack-desc
@@ -11,9 +11,9 @@ lives:
lives: LiVES is a Video Editing System. It is designed to be simple to use,
lives: yet powerful. It is small in size, yet it has many advanced features.
lives:
-lives: Homepage: http://lives-video.com/
-lives:
-lives:
-lives:
+lives: LiVES is good enough to be used as a VJ tool for professional
+lives: performances, and as a video editor is capable of creating dazzling
+lives: clips in a huge variety of formats.
lives:
+lives: Homepage: http://lives.sourceforge.net/
lives: