summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author B. Watson2020-11-20 14:25:42 +0100
committer Willy Sudiarto Raharjo2020-11-21 19:14:17 +0100
commit8507c11e5a57715c9078eabd9d64b3995e1f6504 (patch)
treee9057ec2e277e31ab20de9d8ae292cbf085cbfab
parent14fe7cb8c8d4ca661c563a54b20da0207ec73c1d (diff)
downloadslackbuilds-8507c11e5a57715c9078eabd9d64b3995e1f6504.tar.gz
development/codespell: Added (spell checker for source code)
Signed-off-by: Dave Woodfall <dave@slackbuilds.org> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--development/codespell/README9
-rw-r--r--development/codespell/codespell.SlackBuild67
-rw-r--r--development/codespell/codespell.info10
-rw-r--r--development/codespell/slack-desc19
4 files changed, 105 insertions, 0 deletions
diff --git a/development/codespell/README b/development/codespell/README
new file mode 100644
index 0000000000..6c714b66f2
--- /dev/null
+++ b/development/codespell/README
@@ -0,0 +1,9 @@
+codespell (spell checker for source code)
+
+codespell fixes common misspellings in text files. It's designed
+primarily for checking misspelled words in source code, but it can be
+used with other files as well.
+
+Optional dependency: python-chardet. This is required for codespell's
+-e option. Unless you deal with files that are not ASCII, ISO-8859-1,
+or UTF-8, you probably don't need the -e option.
diff --git a/development/codespell/codespell.SlackBuild b/development/codespell/codespell.SlackBuild
new file mode 100644
index 0000000000..4f0d11f112
--- /dev/null
+++ b/development/codespell/codespell.SlackBuild
@@ -0,0 +1,67 @@
+#!/bin/sh
+
+# Slackware build script for codespell
+
+# Written by B. Watson (yalhcru@gmail.com)
+
+# Licensed under the WTFPL. See http://www.wtfpl.net/txt/copying/ for details.
+
+PRGNAM=codespell
+VERSION=${VERSION:-1.17.1}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . -perm /111 -a \! -perm 755 -a -exec chmod 755 {} \+ -o \
+ \! -perm /111 -a \! -perm 644 -a -exec chmod 644 {} \+
+
+python setup.py install --root=$PKG
+
+make $PRGNAM.1
+mkdir -p $PKG/usr/man/man1
+gzip -9c < $PRGNAM.1 > $PKG/usr/man/man1/$PRGNAM.1.gz
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a README* COPYING $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/development/codespell/codespell.info b/development/codespell/codespell.info
new file mode 100644
index 0000000000..4edb51d153
--- /dev/null
+++ b/development/codespell/codespell.info
@@ -0,0 +1,10 @@
+PRGNAM="codespell"
+VERSION="1.17.1"
+HOMEPAGE="https://github.com/codespell-project/codespell"
+DOWNLOAD="https://github.com/codespell-project/codespell/archive/v1.17.1/codespell-1.17.1.tar.gz"
+MD5SUM="eaa42b26713c571311ba9374046cc12f"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="B. Watson"
+EMAIL="yalhcru@gmail.com"
diff --git a/development/codespell/slack-desc b/development/codespell/slack-desc
new file mode 100644
index 0000000000..bf1da3cc6f
--- /dev/null
+++ b/development/codespell/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+codespell: codespell (spell checker for source code)
+codespell:
+codespell: codespell fixes common misspellings in text files. It's designed
+codespell: primarily for checking misspelled words in source code, but it can be
+codespell: used with other files as well.
+codespell:
+codespell:
+codespell:
+codespell:
+codespell:
+codespell: