summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Leo C2020-04-18 15:43:20 +0200
committer Willy Sudiarto Raharjo2020-04-19 05:00:21 +0200
commita88c304dcec5461595074936fb634ecace644f12 (patch)
tree0fa481c00e514a6c9a030e065c882a17794e3091
parent5c22e6d7cac9e7f271126e0b3045b2c5cbbb1c99 (diff)
downloadslackbuilds-a88c304dcec5461595074936fb634ecace644f12.tar.gz
office/xlsx2csv: Added (xlsx to csv converter).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--office/xlsx2csv/README4
-rw-r--r--office/xlsx2csv/slack-desc19
-rw-r--r--office/xlsx2csv/xlsx2csv.SlackBuild98
-rw-r--r--office/xlsx2csv/xlsx2csv.info10
4 files changed, 131 insertions, 0 deletions
diff --git a/office/xlsx2csv/README b/office/xlsx2csv/README
new file mode 100644
index 0000000000..b74d5b813f
--- /dev/null
+++ b/office/xlsx2csv/README
@@ -0,0 +1,4 @@
+Converts xlsx files to csv format. Handles large XLSX files. Fast and
+easy to use.
+
+Python3 is an optional autodetected dependency
diff --git a/office/xlsx2csv/slack-desc b/office/xlsx2csv/slack-desc
new file mode 100644
index 0000000000..67694ec6f9
--- /dev/null
+++ b/office/xlsx2csv/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+xlsx2csv: xlsx2csv (xlsx to csv converter)
+xlsx2csv:
+xlsx2csv: Converts xlsx files to csv format. Handles large XLSX files. Fast and
+xlsx2csv: easy to use.
+xlsx2csv:
+xlsx2csv:
+xlsx2csv:
+xlsx2csv:
+xlsx2csv:
+xlsx2csv: Homepage: https://github.com/dilshod/xlsx2csv
+xlsx2csv:
diff --git a/office/xlsx2csv/xlsx2csv.SlackBuild b/office/xlsx2csv/xlsx2csv.SlackBuild
new file mode 100644
index 0000000000..491b6b30c4
--- /dev/null
+++ b/office/xlsx2csv/xlsx2csv.SlackBuild
@@ -0,0 +1,98 @@
+#!/bin/sh
+
+# Slackware build script for xlsx2csv
+
+# Copyright 2020 Leonardo Citrolo, Italy
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=xlsx2csv
+VERSION=${VERSION:-0.7.4}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+# Python 3 support.
+if $(python3 -c 'import sys' 2>/dev/null); then
+ python3 setup.py install --root=$PKG
+fi
+
+make -C man
+mkdir -p $PKG/usr/man/man1
+cp -a man/$PRGNAM.1 $PKG/usr/man/man1
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+find $PKG/usr/man -type f -exec gzip -9 {} \;
+for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a CHANGELOG COPYING LICENSE.txt README \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/office/xlsx2csv/xlsx2csv.info b/office/xlsx2csv/xlsx2csv.info
new file mode 100644
index 0000000000..93bf25627d
--- /dev/null
+++ b/office/xlsx2csv/xlsx2csv.info
@@ -0,0 +1,10 @@
+PRGNAM="xlsx2csv"
+VERSION="0.7.4"
+HOMEPAGE="https://github.com/dilshod/xlsx2csv"
+DOWNLOAD="https://github.com/dilshod/xlsx2csv/archive/0.7.4/xlsx2csv-0.7.4.tar.gz"
+MD5SUM="c1fb8b22936bfb696158fba9bc0fae2e"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Leo C."
+EMAIL="leoc@gmx.com"