summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Isaac Yu2020-04-10 05:06:34 +0200
committer Willy Sudiarto Raharjo2020-04-10 05:06:34 +0200
commitddf2b1f7f82c2393c096192f23a352c7aa36b762 (patch)
tree8599f9d7a16fe4a3cf7fca56433b2960ad0ff5d9
parenta12618cee86affbb592795671404804ba2909ae7 (diff)
downloadslackbuilds-ddf2b1f7f82c2393c096192f23a352c7aa36b762.tar.gz
python/python3-soupsieve: Added (A CSS selector implementation).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--python/python3-soupsieve/README6
-rw-r--r--python/python3-soupsieve/python3-soupsieve.SlackBuild87
-rw-r--r--python/python3-soupsieve/python3-soupsieve.info10
-rw-r--r--python/python3-soupsieve/slack-desc19
4 files changed, 122 insertions, 0 deletions
diff --git a/python/python3-soupsieve/README b/python/python3-soupsieve/README
new file mode 100644
index 0000000000..6acf8ef461
--- /dev/null
+++ b/python/python3-soupsieve/README
@@ -0,0 +1,6 @@
+Soup Sieve is a CSS selector library designed to be used with
+Beautiful Soup 4. It aims to provide selecting, matching, and
+filtering using modern CSS selectors.
+
+Soup Sieve >= 2.0.0 has dropped Python 2 support. Hence, the
+python-soupsieve SlackBuild is at version 1.9.5.
diff --git a/python/python3-soupsieve/python3-soupsieve.SlackBuild b/python/python3-soupsieve/python3-soupsieve.SlackBuild
new file mode 100644
index 0000000000..509f03eb4b
--- /dev/null
+++ b/python/python3-soupsieve/python3-soupsieve.SlackBuild
@@ -0,0 +1,87 @@
+#!/bin/sh
+
+# Slackware build script for python3-soupsieve
+
+# Copyright 2020 Isaac Yu <isaacyu1@isaacyu1.com>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=python3-soupsieve
+VERSION=${VERSION:-2.0.0}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+SRCNAM=soupsieve
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python3 setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a *.md docs/ requirements/ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/python3-soupsieve/python3-soupsieve.info b/python/python3-soupsieve/python3-soupsieve.info
new file mode 100644
index 0000000000..4d99b6cf79
--- /dev/null
+++ b/python/python3-soupsieve/python3-soupsieve.info
@@ -0,0 +1,10 @@
+PRGNAM="python3-soupsieve"
+VERSION="2.0.0"
+HOMEPAGE="https://github.com/facelessuser/soupsieve"
+DOWNLOAD="https://github.com/facelessuser/soupsieve/archive/2.0.0/soupsieve-2.0.0.tar.gz"
+MD5SUM="8631cf2c368928a7aaf0313b60d007ce"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="python3"
+MAINTAINER="Isaac Yu"
+EMAIL="isaacyu1@isaacyu1.com"
diff --git a/python/python3-soupsieve/slack-desc b/python/python3-soupsieve/slack-desc
new file mode 100644
index 0000000000..514594ef55
--- /dev/null
+++ b/python/python3-soupsieve/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+python3-soupsieve: python3-soupsieve (A CSS selector implementation for BeautifulSoup)
+python3-soupsieve:
+python3-soupsieve: Soup Sieve is a CSS selector library designed to be used with
+python3-soupsieve: Beautiful Soup 4. It aims to provide selecting, matching, and
+python3-soupsieve: filtering using modern CSS selectors.
+python3-soupsieve:
+python3-soupsieve:
+python3-soupsieve:
+python3-soupsieve:
+python3-soupsieve:
+python3-soupsieve: