summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Isaac Yu2020-04-09 19:52:42 +0200
committer Willy Sudiarto Raharjo2020-04-09 19:52:42 +0200
commit376b6e8b8271864a4412c73f7ddaa7a5baeaaea2 (patch)
treebf3b95f7a738a2ccdb5711fa101a503069e0a201
parent38d284701d09e85ec9892425e7b4b20417cc2fb2 (diff)
downloadslackbuilds-376b6e8b8271864a4412c73f7ddaa7a5baeaaea2.tar.gz
system/libtrash: Added (trash can).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--system/libtrash/README6
-rw-r--r--system/libtrash/libtrash.SlackBuild92
-rw-r--r--system/libtrash/libtrash.info10
-rw-r--r--system/libtrash/slack-desc19
4 files changed, 127 insertions, 0 deletions
diff --git a/system/libtrash/README b/system/libtrash/README
new file mode 100644
index 0000000000..11f5d438de
--- /dev/null
+++ b/system/libtrash/README
@@ -0,0 +1,6 @@
+libtrash is a shared library which, when preloaded, implements a
+trash can under GNU/Linux.
+
+For instance, with libtrash, Midnight Commander will move files
+to the trash directory:
+LD_PRELOAD=/usr/lib/libtrash.so.3.4 mc
diff --git a/system/libtrash/libtrash.SlackBuild b/system/libtrash/libtrash.SlackBuild
new file mode 100644
index 0000000000..67a9514b81
--- /dev/null
+++ b/system/libtrash/libtrash.SlackBuild
@@ -0,0 +1,92 @@
+#!/bin/sh
+
+# Slackware build script for libtrash
+#
+# Copyright 2020 Isaac Yu <isaacyu1@isaacyu1.com>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=libtrash
+VERSION=${VERSION:-3.4}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tgz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+# Inspired by the following Arch Linux AUR script:
+# https://aur.archlinux.org/packages/libtrash/
+sed -i -e s/ldconfig// ./src/Makefile
+sed -i -e s/python/python2/ ./src/Makefile
+
+make
+install -d $PKG/usr/lib $PKG/etc
+make install INSTLIBDIR=$PKG/usr/lib SYSCONFFILE=$PKG/etc/libtrash.conf
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a COPYING README TODO config.txt $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/system/libtrash/libtrash.info b/system/libtrash/libtrash.info
new file mode 100644
index 0000000000..dd83b0c23d
--- /dev/null
+++ b/system/libtrash/libtrash.info
@@ -0,0 +1,10 @@
+PRGNAM="libtrash"
+VERSION="3.4"
+HOMEPAGE="http://pages.stern.nyu.edu/~marriaga/software/libtrash/"
+DOWNLOAD="http://pages.stern.nyu.edu/~marriaga/software/libtrash/libtrash-3.4.tgz"
+MD5SUM="100594b124412a3a34d75bbce28e5c1f"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Isaac Yu"
+EMAIL="isaacyu1@isaacyu1.com"
diff --git a/system/libtrash/slack-desc b/system/libtrash/slack-desc
new file mode 100644
index 0000000000..da3fd74bf4
--- /dev/null
+++ b/system/libtrash/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+libtrash: libtrash (trash can for GNU/Linux)
+libtrash:
+libtrash: libtrash is a shared library which, when preloaded, implements a
+libtrash: trash can under GNU/Linux.
+libtrash:
+libtrash:
+libtrash:
+libtrash:
+libtrash:
+libtrash:
+libtrash: