summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Edinaldo P. Silva2020-02-07 20:05:45 +0100
committer Willy Sudiarto Raharjo2020-02-07 20:05:45 +0100
commit8af363d63ac78992974eabd94741e28b383d7e32 (patch)
tree020577afef0841239a366bad3193e317d1a386de
parent9f8bf7604878538a842c1923f3b6c4b83f9c1c18 (diff)
downloadslackbuilds-8af363d63ac78992974eabd94741e28b383d7e32.tar.gz
development/mutagen: Add python3 support.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--development/mutagen/README5
-rw-r--r--development/mutagen/mutagen.SlackBuild10
2 files changed, 5 insertions, 10 deletions
diff --git a/development/mutagen/README b/development/mutagen/README
index 9356e2d898..b22c7ff981 100644
--- a/development/mutagen/README
+++ b/development/mutagen/README
@@ -14,7 +14,4 @@ individual packet/page level.
Mutagen works with Python 2.7, 3.3+ and has no dependencies outside
the Python standard library.
-NOTE: to build mutagen with python3 run the slackbuild with option
-PYTHON3=yes.
-
- # PYTHON3=yes ./mutagen.SlackBuild
+Optional dependency: python3
diff --git a/development/mutagen/mutagen.SlackBuild b/development/mutagen/mutagen.SlackBuild
index 346ff70570..8e01169988 100644
--- a/development/mutagen/mutagen.SlackBuild
+++ b/development/mutagen/mutagen.SlackBuild
@@ -2,7 +2,7 @@
#
# Slackware build script for mutagen.
#
-# Copyright 2016-2019 Edinaldo P. Silva, Rio de Janeiro, Brazil.
+# Copyright 2016-2020 Edinaldo P. Silva, Rio de Janeiro, Brazil.
# Copyright 2016 Dugan Chen (thedoogster [at] gmail [dot] [com])
# Copyright 2008 Frank Caraballo <fecaraballo{at}gmail{dot}com>
# All rights reserved.
@@ -26,7 +26,7 @@
PRGNAM=mutagen
VERSION=${VERSION:-1.43.0}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@@ -74,12 +74,10 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
-python setup.py build
python setup.py install --root $PKG
-# Build mutagen with python3. Default is no.
-if [ "${PYTHON3:-no}" == "yes" ]; then
- python3 setup.py build
+# Install python3 bindings.
+if $(python3 -c 'import sys' 2>/dev/null); then
python3 setup.py install --root=$PKG
fi