summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Larry Hajali2019-10-03 06:00:22 +0200
committer Willy Sudiarto Raharjo2019-10-05 08:51:56 +0200
commit3a43aaa803ba6c5a4b10383d13dfe91da699aa18 (patch)
treea7b1f42cd042174b41a1a311e67fcb829363a777
parent1b3b2fe62b452191b0f80794fd61cb3de482bc18 (diff)
downloadslackbuilds-3a43aaa803ba6c5a4b10383d13dfe91da699aa18.tar.gz
python/dnspython: Updated for version 1.16.0
Signed-off-by: Larry Hajali <larryhaja[at]gmail[dot]com>
-rw-r--r--python/dnspython/README2
-rw-r--r--python/dnspython/dnspython.SlackBuild20
-rw-r--r--python/dnspython/dnspython.info6
3 files changed, 14 insertions, 14 deletions
diff --git a/python/dnspython/README b/python/dnspython/README
index 8ec893d537..0968ce38dd 100644
--- a/python/dnspython/README
+++ b/python/dnspython/README
@@ -7,5 +7,5 @@ level classes perform queries for data of a given name, type, and
class, and return an answer set. The low level classes allow direct
manipulation of DNS zones, messages, names, and records.
-python3, pycrypto and ecdsa are optional dependencies for DNSSEC
+python3, pycrypto, pycryptodome and ecdsa are optional dependencies for DNSSEC
functionality.
diff --git a/python/dnspython/dnspython.SlackBuild b/python/dnspython/dnspython.SlackBuild
index d5df6ee9e4..65c379b04e 100644
--- a/python/dnspython/dnspython.SlackBuild
+++ b/python/dnspython/dnspython.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for dnspython
-# Copyright 2009-2018 Larry Hajali <larryhaja[at]gmail[dot]com>
+# Copyright 2009-2019 Larry Hajali <larryhaja[at]gmail[dot]com>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -23,13 +23,13 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=dnspython
-VERSION=${VERSION:-1.15.0}
-BUILD=${BUILD:-2}
+VERSION=${VERSION:-1.16.0}
+BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
- i?86) ARCH=i486 ;;
+ i?86) ARCH=i586 ;;
arm*) ARCH=arm ;;
*) ARCH=$( uname -m ) ;;
esac
@@ -50,10 +50,10 @@ tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
python setup.py install --root=$PKG
@@ -61,11 +61,11 @@ if $(python3 -c 'import sys' 2>/dev/null); then
python3 setup.py install --root=$PKG
fi
-find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a ChangeLog LICENSE PKG-INFO $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a LICENSE README.md $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
diff --git a/python/dnspython/dnspython.info b/python/dnspython/dnspython.info
index ed861b5aa4..bda42baf91 100644
--- a/python/dnspython/dnspython.info
+++ b/python/dnspython/dnspython.info
@@ -1,8 +1,8 @@
PRGNAM="dnspython"
-VERSION="1.15.0"
+VERSION="1.16.0"
HOMEPAGE="http://www.dnspython.org/"
-DOWNLOAD="http://www.dnspython.org/kits/1.15.0/dnspython-1.15.0.tar.gz"
-MD5SUM="63a679089822fb86127867c315286dc5"
+DOWNLOAD="http://www.dnspython.org/kits/1.16.0/dnspython-1.16.0.tar.gz"
+MD5SUM="5691e0fbb280ed4eaf182ebedccf3462"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""