summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Benjamin Trigona-Harany2018-10-06 08:25:27 +0200
committer Willy Sudiarto Raharjo2018-10-13 03:03:03 +0200
commitf2f7f5cd3cfb3052c5285c8b8877f7a692eb6cc6 (patch)
treeab4a41942e1c150864da726029c8e6587b6958c5
parent850b4137e6327b88d72338f11658264c240b7f97 (diff)
downloadslackbuilds-f2f7f5cd3cfb3052c5285c8b8877f7a692eb6cc6.tar.gz
python/python-webencodings: Add Python 3 support.
-rw-r--r--python/python-webencodings/python-webencodings.SlackBuild7
-rw-r--r--python/python-webencodings/python-webencodings.info2
2 files changed, 5 insertions, 4 deletions
diff --git a/python/python-webencodings/python-webencodings.SlackBuild b/python/python-webencodings/python-webencodings.SlackBuild
index fe72b0f16b..a07d9cb7d8 100644
--- a/python/python-webencodings/python-webencodings.SlackBuild
+++ b/python/python-webencodings/python-webencodings.SlackBuild
@@ -2,7 +2,7 @@
#
# SlackBuild for python-webencodings
#
-# Copyright 2017 Benjamin Trigona-Harany <slackbuilds@jaxartes.net>
+# Copyright 2017-2018 Benjamin Trigona-Harany <slackbuilds@jaxartes.net>
#
# Redistribution and use of this script, with or without modification, is
# permitted provided that the following conditions are met:
@@ -23,7 +23,7 @@
PRGNAM=python-webencodings
VERSION=${VERSION:-0.5.1}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@@ -68,7 +68,8 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python setup.py install --root=$PKG
+python2 setup.py install --root=$PKG
+python3 setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
diff --git a/python/python-webencodings/python-webencodings.info b/python/python-webencodings/python-webencodings.info
index addf43e15b..5d5c3a5ff5 100644
--- a/python/python-webencodings/python-webencodings.info
+++ b/python/python-webencodings/python-webencodings.info
@@ -5,6 +5,6 @@ DOWNLOAD="https://github.com/gsnedders/python-webencodings/archive/v0.5.1/python
MD5SUM="7eb67377743cd55eaa356496c439471e"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES=""
+REQUIRES="python3"
MAINTAINER="Benjamin Trigona-Harany"
EMAIL="slackbuilds@jaxartes.net"