summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author B. Watson2018-09-16 07:17:40 +0200
committer David Spencer2018-09-22 00:52:42 +0200
commitaf3d874f76c6f32e6518ae0e361b50620a7a58d2 (patch)
tree69c829a9a48f07b005c52f4a1f44ddacf02285d0
parent30f0cf7a9efaf9d0bcdb234af7674edb1836e881 (diff)
downloadslackbuilds-af3d874f76c6f32e6518ae0e361b50620a7a58d2.tar.gz
audio/wmusic: Updated for version 2.0.0.
Signed-off-by: B. Watson <yalhcru@gmail.com> Signed-off-by: David Spencer <idlemoor@slackbuilds.org>
-rw-r--r--audio/wmusic/README12
-rw-r--r--audio/wmusic/kill_glib_assertion_spam.diff27
-rw-r--r--audio/wmusic/slack-desc10
-rw-r--r--audio/wmusic/wmusic.SlackBuild45
-rw-r--r--audio/wmusic/wmusic.info10
5 files changed, 72 insertions, 32 deletions
diff --git a/audio/wmusic/README b/audio/wmusic/README
index 5036260978..d1d544d91d 100644
--- a/audio/wmusic/README
+++ b/audio/wmusic/README
@@ -1,6 +1,14 @@
-wmusic is a dockapp that remote-controls xmms. Here is a list of the features:
+wmusic (audio player remote control dockapp)
+
+wmusic is a dockapp that remote-controls music players. Here is a list
+of the features:
- VCR style controls including fast rewind and fast forward
- Time and Playlist position display
- Super stylee rotating arrow
-- Hiding of the xmms windows (on startup and through middle-click)
+- Hiding of the player window (on startup and through middle-click)
+
+Note: this version of wmusic can only control players that implement
+the MPRIS D-Bus Interface Specification. Examples: audacious, amarok,
+spotify, blc, bmp, xmms... but NOT xmms 1 (the xmms that ships with
+Slackware). Use wmusic-xmms instead, to control xmms 1.
diff --git a/audio/wmusic/kill_glib_assertion_spam.diff b/audio/wmusic/kill_glib_assertion_spam.diff
new file mode 100644
index 0000000000..285b0c744b
--- /dev/null
+++ b/audio/wmusic/kill_glib_assertion_spam.diff
@@ -0,0 +1,27 @@
+diff -Naur wmusic-2.0.0/src/wmusic.c wmusic-2.0.0.patched/src/wmusic.c
+--- wmusic-2.0.0/src/wmusic.c 2018-06-22 16:18:18.000000000 -0400
++++ wmusic-2.0.0.patched/src/wmusic.c 2018-09-16 01:15:17.317552343 -0400
+@@ -374,6 +374,7 @@
+ double volume;
+ double factor;
+
++ if(!player) return;
+ g_object_get(player, "volume", &volume, NULL);
+
+ if (*(int*)data == 1)
+@@ -393,6 +394,7 @@
+ void ChangeVol(int x, int y, DARect rect, void *data)
+ {
+ float volume = ((float)x)/38;
++ if(!player) return;
+ g_object_set(player, "volume", volume, NULL);
+ }
+
+@@ -635,6 +637,7 @@
+ int volume;
+ double volume_double;
+
++ if(!player) return;
+ g_object_get(player, "volume", &volume_double, NULL);
+ volume = (int)(36 * volume_double);
+ if (volume > 36)
diff --git a/audio/wmusic/slack-desc b/audio/wmusic/slack-desc
index dc5b3fb9a9..fd3f559796 100644
--- a/audio/wmusic/slack-desc
+++ b/audio/wmusic/slack-desc
@@ -6,13 +6,13 @@
# customary to leave one space after the ':' except on otherwise blank lines.
|-----handy-ruler------------------------------------------------------|
-wmusic: wmusic (XMMS Remote Control DockApp)
+wmusic: wmusic (audio player remote control dockapp)
+wmusic:
+wmusic: wmusic is a dockapp that remote-controls various music
+wmusic: players. Features VCR style fast forward and rewind, time and
+wmusic: playlist position display, hiding of player window and more.
wmusic:
-wmusic: wmusic is a dockapp that remote-controls xmms. Features VCR style fast
-wmusic: forward and rewind, time and playlist position display, hiding of XMMS
-wmusic: window and more.
wmusic:
-wmusic: Homepage: http://home.jtan.com/~john/wmusic/
wmusic:
wmusic:
wmusic:
diff --git a/audio/wmusic/wmusic.SlackBuild b/audio/wmusic/wmusic.SlackBuild
index 46de480ff5..e3b032c518 100644
--- a/audio/wmusic/wmusic.SlackBuild
+++ b/audio/wmusic/wmusic.SlackBuild
@@ -27,6 +27,8 @@
# Currently maintained by B. Watson <yalhcru@gmail.com>
+# 20180916 bkw: update for v2.0.0.
+
# 20160816 bkw:
# - take over maintenance
# - BUILD=2
@@ -35,8 +37,8 @@
# - remove 'see the Info files' from man page, as there is no info file.
PRGNAM=wmusic
-VERSION=${VERSION:-1.5.0}
-BUILD=${BUILD:-2}
+VERSION=${VERSION:-2.0.0}
+BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@@ -75,28 +77,31 @@ rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-# ./configure ignores CFLAGS, hence the sed stuff. -include string.h
-# kills a couple of warnings.
-./configure
-sed -i "s,-g -O2,$SLKCFLAGS -include string.h," src/Makefile
-make
+find -L . -perm /111 -a \! -perm 755 -a -exec chmod 755 {} \+ -o \
+ \! -perm /111 -a \! -perm 644 -a -exec chmod 644 {} \+
-# 'make install' ignores DESTDIR, it's only 1 file anyway.
-mkdir -p $PKG/usr/bin
-install -s -m0755 src/wmusic $PKG/usr/bin
+# Stop spewing these:
+# GLib-GObject-CRITICAL **: g_object_get: assertion 'G_IS_OBJECT (object)' failed
+patch -p1 < $CWD/kill_glib_assertion_spam.diff
-mkdir -p $PKG/usr/man/man1
-sed '/see the Info files/d' debian/$PRGNAM.1 | \
- gzip -9c > $PKG/usr/man/man1/$PRGNAM.1.gz
+CFLAGS="$SLKCFLAGS" \
+CXXFLAGS="$SLKCFLAGS" \
+./configure \
+ --prefix=/usr \
+ --libdir=/usr/lib${LIBDIRSUFFIX} \
+ --sysconfdir=/etc \
+ --localstatedir=/var \
+ --mandir=/usr/man \
+ --docdir=/usr/doc/$PRGNAM-$VERSION \
+ --build=$ARCH-slackware-linux
+
+make
+sed -i '/see the Info files/d' $PRGNAM.1
+make install-strip DESTDIR=$PKG
+gzip -9 $PKG/usr/man/man1/$PRGNAM.1
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a README COPYING $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a README COPYING ChangeLog $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
diff --git a/audio/wmusic/wmusic.info b/audio/wmusic/wmusic.info
index 177f38f9d9..c9164312bf 100644
--- a/audio/wmusic/wmusic.info
+++ b/audio/wmusic/wmusic.info
@@ -1,10 +1,10 @@
PRGNAM="wmusic"
-VERSION="1.5.0"
-HOMEPAGE="https://web.archive.org/web/20050405110012/http://home.jtan.com/~john/wmusic/"
-DOWNLOAD="https://web.archive.org/web/20070508045423/http://home.jtan.com/~john/wmusic/wmusic-1.5.0.tar.gz"
-MD5SUM="20b39e0528089161998e2b0c77b1e4ea"
+VERSION="2.0.0"
+HOMEPAGE="https://www.dockapps.net/wmusic"
+DOWNLOAD="https://www.dockapps.net/download/wmusic-2.0.0.tar.gz"
+MD5SUM="fddcc72d6f497ef765164fc4eeb3ac19"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES=""
+REQUIRES="libdockapp playerctl"
MAINTAINER="B. Watson"
EMAIL="yalhcru@gmail.com"