summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Andrew Clemons2018-04-12 11:11:42 +0200
committer Willy Sudiarto Raharjo2018-04-28 01:40:22 +0200
commit1d05fe4ffa59f7764e999a0c0421cf960a36f345 (patch)
treea45728f11cd42b23bbd271eb65cd00b1c33537c3
parent0e6ee67a63f43e32b12db947554c7ca6bc2f6c18 (diff)
downloadslackbuilds-1d05fe4ffa59f7764e999a0c0421cf960a36f345.tar.gz
system/fwupdate: Updated for version 11.
Signed-off-by: Andrew Clemons <andrew.clemons@gmail.com>
-rw-r--r--system/fwupdate/fwupdate.SlackBuild7
-rw-r--r--system/fwupdate/fwupdate.info6
-rw-r--r--system/fwupdate/patches/7b593644bebe63cf73233e835c18d7bbdb8d063f.patch30
3 files changed, 39 insertions, 4 deletions
diff --git a/system/fwupdate/fwupdate.SlackBuild b/system/fwupdate/fwupdate.SlackBuild
index 3e48ff38c5..0cf442e001 100644
--- a/system/fwupdate/fwupdate.SlackBuild
+++ b/system/fwupdate/fwupdate.SlackBuild
@@ -23,7 +23,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=fwupdate
-VERSION=${VERSION:-10}
+VERSION=${VERSION:-11}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -62,6 +62,11 @@ cd $TMP
rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
+
+for sha1 in 7b593644bebe63cf73233e835c18d7bbdb8d063f ; do
+ patch -p1 < $CWD/patches/$sha1.patch
+done
+
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
diff --git a/system/fwupdate/fwupdate.info b/system/fwupdate/fwupdate.info
index b0e686becd..88edec9100 100644
--- a/system/fwupdate/fwupdate.info
+++ b/system/fwupdate/fwupdate.info
@@ -1,8 +1,8 @@
PRGNAM="fwupdate"
-VERSION="10"
+VERSION="11"
HOMEPAGE="https://github.com/rhboot/fwupdate"
-DOWNLOAD="https://github.com/rhboot/fwupdate/archive/10/fwupdate-10.tar.gz"
-MD5SUM="9724a9848b29d935e135a7bec7fa7349"
+DOWNLOAD="https://github.com/rhboot/fwupdate/archive/11/fwupdate-11.tar.gz"
+MD5SUM="4a0ce7eb1ab55dc5c49d865b94f79003"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="efivar libsmbios"
diff --git a/system/fwupdate/patches/7b593644bebe63cf73233e835c18d7bbdb8d063f.patch b/system/fwupdate/patches/7b593644bebe63cf73233e835c18d7bbdb8d063f.patch
new file mode 100644
index 0000000000..f5cff32ad3
--- /dev/null
+++ b/system/fwupdate/patches/7b593644bebe63cf73233e835c18d7bbdb8d063f.patch
@@ -0,0 +1,30 @@
+From 7b593644bebe63cf73233e835c18d7bbdb8d063f Mon Sep 17 00:00:00 2001
+From: Mario Limonciello <mario.limonciello@dell.com>
+Date: Thu, 19 Apr 2018 09:28:44 -0500
+Subject: [PATCH] efi/fwupdate.c Correct a typographical error
+
+gcc -Og -g3 -Werror=format-security -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector-strong --param=ssp-buffer-size=4 -grecord-gcc-switches -fpic -Werror -Wall -Wextra -fshort-wchar -fno-merge-constants -ffreestanding -fno-stack-protector -fno-stack-check --std=gnu11 -DCONFIG_x86_64 -I/usr/include/efi/ -I/usr/include/efi/x86_64/ -iquote/build/include "-DDEBUGDIR=L\"/\"" -mno-mmx -mno-sse -mno-red-zone -nostdinc -maccumulate-outgoing-args -DEFI_FUNCTION_WRAPPER -DGNU_EFI_USE_MS_ABI -I/usr/lib/gcc/x86_64-linux-gnu/7/include -c -o fwupdate.o fwupdate.c
+fwupdate.c: In function 'msleep':
+fwupdate.c:54:2: error: 'gBS' undeclared (first use in this function); did you mean 'BS'?
+ gBS->Stall(msecs);
+ ^~~
+ BS
+fwupdate.c:54:2: note: each undeclared identifier is reported only once for each function it appears in
+/build/efi/Makefile:113: recipe for target 'fwupdate.o' failed
+---
+ efi/fwupdate.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/efi/fwupdate.c b/efi/fwupdate.c
+index 464a226..35c9266 100644
+--- a/efi/fwupdate.c
++++ b/efi/fwupdate.c
+@@ -51,7 +51,7 @@ static int debugging;
+ static VOID
+ msleep(unsigned long msecs)
+ {
+- gBS->Stall(msecs);
++ BS->Stall(msecs);
+ }
+
+