summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Markus Rinne2018-04-18 11:41:23 +0200
committer Willy Sudiarto Raharjo2018-04-21 02:43:00 +0200
commitfbe026ca33e0e7f3c2e44b1ccd87e2916d8eb5d3 (patch)
treef543b65e882889e3f7a9a01e81607f13baa38014
parent6621c706af2d655d6a5d8a4065e4e97de51d1e8b (diff)
downloadslackbuilds-fbe026ca33e0e7f3c2e44b1ccd87e2916d8eb5d3.tar.gz
python/mini-amf: Added (Action Message Format support for Python).
Signed-off-by: David Spencer <idlemoor@slackbuilds.org>
-rw-r--r--python/mini-amf/README9
-rw-r--r--python/mini-amf/mini-amf.SlackBuild87
-rw-r--r--python/mini-amf/mini-amf.info10
-rw-r--r--python/mini-amf/slack-desc19
4 files changed, 125 insertions, 0 deletions
diff --git a/python/mini-amf/README b/python/mini-amf/README
new file mode 100644
index 0000000000..0a99e76399
--- /dev/null
+++ b/python/mini-amf/README
@@ -0,0 +1,9 @@
+Mini-AMF provides Action Message Format serialization and deserialization
+support for Python, compatible with the Adobe Flash Player. It supports
+Python 2.7 and 3.4+.
+
+Mini-AMF is a trimmed-down version of PyAMF. It provides only the core
+serialization and deserialization primitives, and support for reading and
+writing LSO objects on disk. Support for Flex-specific types, "remoting", and
+integration with web frameworks has all been removed. (Adapter classes are
+still supported.)
diff --git a/python/mini-amf/mini-amf.SlackBuild b/python/mini-amf/mini-amf.SlackBuild
new file mode 100644
index 0000000000..32338a1193
--- /dev/null
+++ b/python/mini-amf/mini-amf.SlackBuild
@@ -0,0 +1,87 @@
+#!/bin/sh
+
+# Slackware build script for mini-amf
+
+# Copyright 2018 Markus Rinne Finland
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=mini-amf
+VERSION=${VERSION:-0.9.1}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ CHANGES.rst LICENSE.txt README.rst \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/mini-amf/mini-amf.info b/python/mini-amf/mini-amf.info
new file mode 100644
index 0000000000..fc2399fdb1
--- /dev/null
+++ b/python/mini-amf/mini-amf.info
@@ -0,0 +1,10 @@
+PRGNAM="mini-amf"
+VERSION="0.9.1"
+HOMEPAGE="https://github.com/zackw/mini-amf"
+DOWNLOAD="https://github.com/zackw/mini-amf/archive/v0.9.1/mini-amf-0.9.1.tar.gz"
+MD5SUM="db1bcaf3eb8f7a55876e028c95332584"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="defusedxml"
+MAINTAINER="Markus Rinne"
+EMAIL="markus.ka.rinne@gmail.com"
diff --git a/python/mini-amf/slack-desc b/python/mini-amf/slack-desc
new file mode 100644
index 0000000000..9a4095f1cd
--- /dev/null
+++ b/python/mini-amf/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+mini-amf: mini-amf (Action Message Format support for Python)
+mini-amf:
+mini-amf: Mini-AMF provides Action Message Format serialization and
+mini-amf: deserialization support for Python, compatible with the Adobe Flash
+mini-amf: Player. It supports Python 2.7 and 3.4+.
+mini-amf:
+mini-amf: Mini-AMF is a trimmed-down version of PyAMF. It provides only the
+mini-amf: core serialization and deserialization primitives, and support for
+mini-amf: reading and writing LSO objects on disk. Support for Flex-specific
+mini-amf: types, "remoting", and integration with web frameworks has all been
+mini-amf: removed. (Adapter classes are still supported.)