summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Edinaldo P. Silva2018-04-19 03:57:49 +0200
committer Willy Sudiarto Raharjo2018-04-19 03:57:49 +0200
commitc68f7793cdbae7a0c318787cf130a12453982d55 (patch)
treee56e35bf8b305e04d55479901c162942275c233a
parent7d717f7c0a11d7c395de0a1928120a707aa87814 (diff)
downloadslackbuilds-c68f7793cdbae7a0c318787cf130a12453982d55.tar.gz
libraries/pyPEG2: Update SlackBuild and README.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--libraries/pyPEG2/README4
-rw-r--r--libraries/pyPEG2/pyPEG2.SlackBuild8
2 files changed, 7 insertions, 5 deletions
diff --git a/libraries/pyPEG2/README b/libraries/pyPEG2/README
index baf2045383..09f4d7d1ae 100644
--- a/libraries/pyPEG2/README
+++ b/libraries/pyPEG2/README
@@ -5,7 +5,9 @@ for Python version 2.7 and 3.x. It is based on Parsing Expression
Grammar (PEG). With pyPEG you can parse many formal languages in a
very easy way.
-NOTE: to build mutagen with python3 run the slackbuild with option
+NOTE: to build pyPEG2 with python3 run the slackbuild with option
PYTHON3=yes.
# PYTHON3=yes ./pyPEG2.SlackBuild
+
+NOTE2: In this case 'lxml' need to be build with Python3 bindings.
diff --git a/libraries/pyPEG2/pyPEG2.SlackBuild b/libraries/pyPEG2/pyPEG2.SlackBuild
index 669bcfbf82..bed8af19c4 100644
--- a/libraries/pyPEG2/pyPEG2.SlackBuild
+++ b/libraries/pyPEG2/pyPEG2.SlackBuild
@@ -2,7 +2,7 @@
#
# Slackware build script for pyPEG2.
#
-# Copyright 2015-2017 Edinaldo P. Silva, Rio de Janeiro, Brazil.
+# Copyright 2015-2018 Edinaldo P. Silva, Rio de Janeiro, Brazil.
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -24,7 +24,7 @@
PRGNAM=pyPEG2
VERSION=${VERSION:-2.15.2}
-BUILD=${BUILD:-3}
+BUILD=${BUILD:-4}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@@ -72,7 +72,7 @@ find -L . \
python setup.py build
python setup.py install --root=$PKG
-# Build mutagen with python3. Default is no.
+# Build pyPEG2 with python3. Default is no.
if [ "${PYTHON3:-no}" == "yes" ]; then
python3 setup.py build
python3 setup.py install --root=$PKG
@@ -82,7 +82,7 @@ find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | gr
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a CHANGES.txt LICENSE.txt PKG-INFO README.txt TODO.txt $PKG/usr/doc/$PRGNAM-$VERSION
+cp CHANGES.txt LICENSE.txt PKG-INFO README.txt TODO.txt $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install