summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Benjamin Trigona-Harany2018-03-17 03:54:38 +0100
committer Willy Sudiarto Raharjo2018-03-24 00:50:33 +0100
commitcd19384dc3a1a5a77bc9e946205f5a09da2a81ae (patch)
tree68c11e5541aac138d45cda16dcb62f872f0c38e5
parent18a734cfcd23a5bc8ab9779015da3377d45820dd (diff)
downloadslackbuilds-cd19384dc3a1a5a77bc9e946205f5a09da2a81ae.tar.gz
libraries/msgpack-c: Script clean up.
Signed-off-by: Benjamin Trigona-Harany <bosth@alumni.sfu.ca>
-rw-r--r--libraries/msgpack-c/msgpack-c.SlackBuild19
1 files changed, 9 insertions, 10 deletions
diff --git a/libraries/msgpack-c/msgpack-c.SlackBuild b/libraries/msgpack-c/msgpack-c.SlackBuild
index 550a7559f0..9aa2184804 100644
--- a/libraries/msgpack-c/msgpack-c.SlackBuild
+++ b/libraries/msgpack-c/msgpack-c.SlackBuild
@@ -2,7 +2,7 @@
# SlackBuild script for msgpack-c
-# Copyright 2014 Benjamin Trigona-Harany <slackbuilds@jaxartes.net>
+# Copyright 2014-2018 Benjamin Trigona-Harany <slackbuilds@jaxartes.net>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -68,20 +68,19 @@ find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
-o -perm 511 \) -exec chmod 755 {} \; -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-# this fixes install and msgpack.pc
-sed -i "s/\/lib/\/lib${LIBDIRSUFFIX}/" CMakeLists.txt
-
-cmake \
+mkdir -p build
+cd build
+ cmake \
-DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
-DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS" \
-DCMAKE_BUILD_TYPE=Release \
-DCMAKE_INSTALL_PREFIX=/usr \
- -DCMAKE_INSTALL_LIBDIR=/usr/lib${LIBDIRSUFFIX} .
-
-make
-make install DESTDIR=$PKG
+ -DCMAKE_INSTALL_LIBDIR=/usr/lib${LIBDIRSUFFIX} \
+ ..
+ make install DESTDIR=$PKG
+cd ..
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true