summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Andrew Clemons2017-11-12 20:44:49 +0100
committer Willy Sudiarto Raharjo2017-11-18 06:40:21 +0100
commit8c0911535e5d486586e869ee26c96069db94082d (patch)
tree4ee43bc39004f95a41093ca4e310cee70c744f6e
parent9253cb1573fe64460d7cfe969b151f4c0c25a0d6 (diff)
downloadslackbuilds-8c0911535e5d486586e869ee26c96069db94082d.tar.gz
libraries/json-parser: Added (very low footprint JSON parser).
Signed-off-by: David Spencer <idlemoor@slackbuilds.org>
-rw-r--r--libraries/json-parser/README1
-rw-r--r--libraries/json-parser/json-parser.SlackBuild102
-rw-r--r--libraries/json-parser/json-parser.info10
-rw-r--r--libraries/json-parser/patches/ef2e7454cae8dab485ec4cbce85134a7b7bd7ecd.patch66
-rw-r--r--libraries/json-parser/slack-desc19
5 files changed, 198 insertions, 0 deletions
diff --git a/libraries/json-parser/README b/libraries/json-parser/README
new file mode 100644
index 0000000000..51a6ca847a
--- /dev/null
+++ b/libraries/json-parser/README
@@ -0,0 +1 @@
+json-parser - Very low footprint JSON parser written in portable ANSI C
diff --git a/libraries/json-parser/json-parser.SlackBuild b/libraries/json-parser/json-parser.SlackBuild
new file mode 100644
index 0000000000..0829564b44
--- /dev/null
+++ b/libraries/json-parser/json-parser.SlackBuild
@@ -0,0 +1,102 @@
+#!/bin/sh
+
+# Slackware build script for json-parser
+
+# Copyright 2017 Andrew Clemons, Wellington New Zealand
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=json-parser
+VERSION=${VERSION:-1.1.0}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+patch -p1 < $CWD/patches/ef2e7454cae8dab485ec4cbce85134a7b7bd7ecd.patch
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+autoreconf -vfi
+
+CFLAGS="$SLKCFLAGS" \
+CXXFLAGS="$SLKCFLAGS" \
+./configure \
+ --prefix=/usr \
+ --libdir=/usr/lib${LIBDIRSUFFIX} \
+ --sysconfdir=/etc \
+ --localstatedir=/var \
+ --mandir=/usr/man \
+ --docdir=/usr/doc/$PRGNAM-$VERSION \
+ --build=$ARCH-slackware-linux
+
+make
+make install-shared DESTDIR=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ AUTHORS LICENSE README.md \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/libraries/json-parser/json-parser.info b/libraries/json-parser/json-parser.info
new file mode 100644
index 0000000000..b9d59a6d15
--- /dev/null
+++ b/libraries/json-parser/json-parser.info
@@ -0,0 +1,10 @@
+PRGNAM="json-parser"
+VERSION="1.1.0"
+HOMEPAGE="https://github.com/udp/json-parser"
+DOWNLOAD="https://github.com/udp/json-parser/archive/v1.1.0/json-parser-1.1.0.tar.gz"
+MD5SUM="89eed040e3b0b0ca7eab030e4de562b3"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Andrew Clemons"
+EMAIL="andrew.clemons@gmail.com"
diff --git a/libraries/json-parser/patches/ef2e7454cae8dab485ec4cbce85134a7b7bd7ecd.patch b/libraries/json-parser/patches/ef2e7454cae8dab485ec4cbce85134a7b7bd7ecd.patch
new file mode 100644
index 0000000000..8a0b3173b3
--- /dev/null
+++ b/libraries/json-parser/patches/ef2e7454cae8dab485ec4cbce85134a7b7bd7ecd.patch
@@ -0,0 +1,66 @@
+From ef2e7454cae8dab485ec4cbce85134a7b7bd7ecd Mon Sep 17 00:00:00 2001
+From: Igor Gnatenko <i.gnatenko.brain@gmail.com>
+Date: Wed, 14 May 2014 14:58:27 +0400
+Subject: [PATCH] improve pkgconfig module (close #37)
+
+Signed-off-by: Igor Gnatenko <i.gnatenko.brain@gmail.com>
+---
+ Makefile.in | 4 ++++
+ configure.ac | 4 +++-
+ json-parser.pc.in | 10 ++++++++++
+ 3 files changed, 17 insertions(+), 1 deletion(-)
+ create mode 100644 json-parser.pc.in
+
+diff --git a/Makefile.in b/Makefile.in
+index 85e9e38..68e0b33 100644
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -4,6 +4,7 @@ prefix = @prefix@
+
+ includedir = $(DESTDIR)@includedir@
+ libdir = $(DESTDIR)@libdir@
++datadir = $(DESTDIR)@datadir@
+
+ AR = @AR@
+ CC = @CC@
+@@ -40,6 +41,9 @@ clean:
+ rm -f libjsonparser.$(SO_EXT) libjsonparser.a json.o
+
+ install-shared: libjsonparser.$(SO_EXT)
++ @echo Installing pkgconfig module: $(datadir)/pkgconfig/json-parser.pc
++ @install -d $(datadir)/pkgconfig/ || true
++ @install -m 0644 json-parser.pc $(datadir)/pkgconfig/json-parser.pc
+ @echo Installing shared library: $(libdir)/libjsonparser.$(SO_EXT)
+ @install -d $(libdir) || true
+ @install -m 0755 libjsonparser.$(SO_EXT) $(libdir)/$(REAL_NAME)
+diff --git a/configure.ac b/configure.ac
+index 8e73fc3..2111634 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -22,7 +22,9 @@ fi
+
+ AC_SUBST(VERSION_MAJOR, $VERSION_MAJOR)
+
+-AC_CONFIG_FILES([Makefile])
++AC_CONFIG_FILES([
++ Makefile
++ json-parser.pc])
+
+ AC_OUTPUT
+
+diff --git a/json-parser.pc.in b/json-parser.pc.in
+new file mode 100644
+index 0000000..fc743c4
+--- /dev/null
++++ b/json-parser.pc.in
+@@ -0,0 +1,10 @@
++prefix=@prefix@
++exec_prefix=@exec_prefix@
++libdir=@libdir@
++includedir=@includedir@
++
++Name: json-parser
++Description: Very low footprint JSON parser written in portable ANSI C
++Version: @VERSION_MAJOR@
++Libs: -L${libdir} -ljsonparser
++Cflags: -I${includedir}/json-parser
diff --git a/libraries/json-parser/slack-desc b/libraries/json-parser/slack-desc
new file mode 100644
index 0000000000..a0c0d7a79d
--- /dev/null
+++ b/libraries/json-parser/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+json-parser: json-parser (very low footprint JSON parser)
+json-parser:
+json-parser: Very low footprint JSON parser written in portable ANSI C.
+json-parser:
+json-parser: https://github.com/udp/json-parser
+json-parser:
+json-parser:
+json-parser:
+json-parser:
+json-parser:
+json-parser: