summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Matteo Bernardini2017-06-26 17:48:35 +0200
committer Willy Sudiarto Raharjo2017-07-01 02:43:16 +0200
commit4ba675e1643bf1787fda0311f08cc7cfc0f63d6a (patch)
tree55099a3f30241aa82afe7d53c7d0dc294c9bf626
parent80e7977bad3f750256dad96745e6fb42b3d35cc4 (diff)
downloadslackbuilds-4ba675e1643bf1787fda0311f08cc7cfc0f63d6a.tar.gz
python/turses: Removed (abandoned upstream).
Signed-off-by: Matteo Bernardini <ponce@slackbuilds.org>
-rw-r--r--python/turses/README4
-rw-r--r--python/turses/slack-desc19
-rw-r--r--python/turses/turses.SlackBuild86
-rw-r--r--python/turses/turses.info10
4 files changed, 0 insertions, 119 deletions
diff --git a/python/turses/README b/python/turses/README
deleted file mode 100644
index 8d8f31bf20..0000000000
--- a/python/turses/README
+++ /dev/null
@@ -1,4 +0,0 @@
-turses (ncurses Twitter client)
-
-The goal of the project is to build a full-featured, lightweight,
-and extremely configurable Twitter client.
diff --git a/python/turses/slack-desc b/python/turses/slack-desc
deleted file mode 100644
index 580c4ebb8e..0000000000
--- a/python/turses/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-turses: turses (ncurses twitter client)
-turses:
-turses: The goal of the project is to build a full-featured, lightweight,
-turses: and extremely configurable Twitter client.
-turses:
-turses: homepage: https://github.com/dialelo/turses
-turses:
-turses:
-turses:
-turses:
-turses:
diff --git a/python/turses/turses.SlackBuild b/python/turses/turses.SlackBuild
deleted file mode 100644
index 5398ecb916..0000000000
--- a/python/turses/turses.SlackBuild
+++ /dev/null
@@ -1,86 +0,0 @@
-#!/bin/sh
-
-# Slackware build script for turses
-# Copyright 2013-2015 Matteo Bernardini <ponce@slackbuilds.org>, Pisa, Italy
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-PRGNAM=turses
-VERSION=${VERSION:-20150102_4d7fb2a}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i486 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-DOCS="AUTHORS HISTORY.rst LICENSE README.rst"
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.?z*
-cd $PRGNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
-
-python setup.py install --root=$PKG
-
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a $DOCS $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/turses/turses.info b/python/turses/turses.info
deleted file mode 100644
index 44bdd9d167..0000000000
--- a/python/turses/turses.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="turses"
-VERSION="20150102_4d7fb2a"
-HOMEPAGE="https://github.com/dialelo/turses"
-DOWNLOAD="http://ponce.cc/slackware/sources/repo/turses-20150102_4d7fb2a.tar.xz"
-MD5SUM="4c344d4844d1eb09fbb35f30ef4a28e7"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES="httplib2 tweepy"
-MAINTAINER="Matteo Bernardini"
-EMAIL="ponce@slackbuilds.org"