summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Reedych2016-11-02 14:54:46 +0100
committer Willy Sudiarto Raharjo2016-11-02 16:38:03 +0100
commit3c8c0fbe365be786767e1e7ae4d7f8681d99ccec (patch)
tree51969909d69edfd5add68b7c6c2ff8b0ad6e70bb
parent264941b6473677f351a4d92177ae906a0481700e (diff)
downloadslackbuilds-3c8c0fbe365be786767e1e7ae4d7f8681d99ccec.tar.gz
python/trezor: Added (Bitcoin Hardware Wallet).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--python/trezor/README1
-rw-r--r--python/trezor/slack-desc19
-rw-r--r--python/trezor/trezor.SlackBuild85
-rw-r--r--python/trezor/trezor.info10
4 files changed, 115 insertions, 0 deletions
diff --git a/python/trezor/README b/python/trezor/README
new file mode 100644
index 0000000000..4f75de70a0
--- /dev/null
+++ b/python/trezor/README
@@ -0,0 +1 @@
+Client side implementation for TREZOR-compatible Bitcoin hardware wallets.
diff --git a/python/trezor/slack-desc b/python/trezor/slack-desc
new file mode 100644
index 0000000000..405826e74e
--- /dev/null
+++ b/python/trezor/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+trezor: trezor (Bitcoin Hardware Wallet)
+trezor:
+trezor: Client side implementation for TREZOR-compatible Bitcoin hardware
+trezor: wallets.
+trezor:
+trezor: See http://bitcointrezor.com for more information.
+trezor:
+trezor:
+trezor:
+trezor:
+trezor:
diff --git a/python/trezor/trezor.SlackBuild b/python/trezor/trezor.SlackBuild
new file mode 100644
index 0000000000..ca54653ac2
--- /dev/null
+++ b/python/trezor/trezor.SlackBuild
@@ -0,0 +1,85 @@
+#!/bin/sh
+
+# Slackware build script for trezor
+
+# Copyright (c) 2016 Reedych <reedych@reedych.pw>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=trezor
+VERSION=${VERSION:-0.7.6}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a README.rst $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/trezor/trezor.info b/python/trezor/trezor.info
new file mode 100644
index 0000000000..6a042dee04
--- /dev/null
+++ b/python/trezor/trezor.info
@@ -0,0 +1,10 @@
+PRGNAM="trezor"
+VERSION="0.7.6"
+HOMEPAGE="https://github.com/trezor/trezor"
+DOWNLOAD="https://pypi.python.org/packages/b6/ac/894f90d9d435c26d376559c4b4f08c2e326d5abcadeb4e9b28695228ffb1/trezor-0.7.6.tar.gz"
+MD5SUM="c0c59a7000b3c121f26923ac9f660dbd"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="ecdsa protobuf mnemonic hidapi"
+MAINTAINER="Reedych"
+EMAIL="reedych@reedych.pw"