summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Dimitris Zlatanidis2016-09-22 17:51:10 +0200
committer Willy Sudiarto Raharjo2016-09-24 02:05:14 +0200
commit65b3b30bd646a410c5be728a7f038a35e7966ded (patch)
tree0a36c1d20679e57fe6f6ad663bb883cf3cf5f942
parentf9cabd3c63b2ce7eef03255c20513b0aa06fde01 (diff)
downloadslackbuilds-65b3b30bd646a410c5be728a7f038a35e7966ded.tar.gz
python/pygrametl: Updated for version 2.5.0.
Signed-off-by: Dimitris Zlatanidis <d.zlatanidis@gmail.com>
-rw-r--r--python/pygrametl/pygrametl.SlackBuild17
-rw-r--r--python/pygrametl/pygrametl.info6
2 files changed, 12 insertions, 11 deletions
diff --git a/python/pygrametl/pygrametl.SlackBuild b/python/pygrametl/pygrametl.SlackBuild
index fb8cf8e02d..6ee8f6bfec 100644
--- a/python/pygrametl/pygrametl.SlackBuild
+++ b/python/pygrametl/pygrametl.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for pygrametl
-# Copyright 2014 Dimitris Zlatanidis Greece-Orestiada
+# Copyright 2014-2016 Dimitris Zlatanidis Orestiada, Greece
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -23,13 +23,14 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=pygrametl
-VERSION=${VERSION:-2.3.2}
+VERSION=${VERSION:-2.5.0}
+SRCVER=$(printf $VERSION | cut -c1-3)
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
- i?86) ARCH=i486 ;;
+ i?86) ARCH=i586 ;;
arm*) ARCH=arm ;;
*) ARCH=$( uname -m ) ;;
esac
@@ -40,8 +41,8 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
@@ -59,15 +60,15 @@ set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
-rm -rf $PRGNAM-$VERSION
+rm -rf $PRGNAM-$SRCVER
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$VERSION
+cd $PRGNAM-$SRCVER
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
-o -perm 511 \) -exec chmod 755 {} \; -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
python setup.py install --root=$PKG
diff --git a/python/pygrametl/pygrametl.info b/python/pygrametl/pygrametl.info
index 2645d71589..63861da847 100644
--- a/python/pygrametl/pygrametl.info
+++ b/python/pygrametl/pygrametl.info
@@ -1,8 +1,8 @@
PRGNAM="pygrametl"
-VERSION="2.3.2"
+VERSION="2.5.0"
HOMEPAGE="http://pygrametl.org/"
-DOWNLOAD="https://pypi.python.org/packages/source/p/pygrametl/pygrametl-2.3.2.tar.gz"
-MD5SUM="3248f5a9830cf37f639ae27c47740bf6"
+DOWNLOAD="https://pypi.python.org/packages/85/59/2f314c8d9c876a432b85683b542d221bcceb885fe33a960c2d9be8f5c90c/pygrametl-2.5.0.tar.gz"
+MD5SUM="bb140db0b887b878a9db4d427a928aff"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""