summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Mario Preksavec2016-09-04 17:21:54 +0200
committer Willy Sudiarto Raharjo2016-09-11 03:53:21 +0200
commit6f7d252327e4559f12c7cc6ec6f6d40a110cee00 (patch)
tree6415db9bb4eb89b438ea24cbe40155d305fa61ba
parent007274adc16df24101ca1c2b898e80d169b2dd57 (diff)
downloadslackbuilds-6f7d252327e4559f12c7cc6ec6f6d40a110cee00.tar.gz
python/python-django-tagging: Updated for version 0.4.3.
Signed-off-by: Mario Preksavec <mario@slackware.hr>
-rw-r--r--python/python-django-tagging/patches/fix_calc_tag_weight19
-rw-r--r--python/python-django-tagging/python-django-tagging.SlackBuild8
-rw-r--r--python/python-django-tagging/python-django-tagging.info6
3 files changed, 6 insertions, 27 deletions
diff --git a/python/python-django-tagging/patches/fix_calc_tag_weight b/python/python-django-tagging/patches/fix_calc_tag_weight
deleted file mode 100644
index 1b65164453..0000000000
--- a/python/python-django-tagging/patches/fix_calc_tag_weight
+++ /dev/null
@@ -1,19 +0,0 @@
-Description: Fix tag_weight when using logarithmic distribution
- When logarithmic distribution is used _calculate_tag_weight may
- return weight greater than maximum threshold. Because of this the attribute
- font_size of the most frequently used tag may be left unset.
-Upstream: http://code.google.com/p/django-tagging/issues/detail?id=91
-Debian: #525770
-
---- django-tagging.old/tagging/utils.py (revision 132)
-+++ django-tagging/tagging/utils.py (working copy)
-@@ -230,7 +230,7 @@
- if distribution == LINEAR or max_weight == 1:
- return weight
- elif distribution == LOGARITHMIC:
-- return math.log(weight) * max_weight / math.log(max_weight)
-+ return min((max_weight, math.log(weight) * max_weight / math.log(max_weight)))
- raise ValueError(_('Invalid distribution algorithm specified: %s.') % distribution)
-
- def calculate_cloud(tags, steps=4, distribution=LOGARITHMIC):
-
diff --git a/python/python-django-tagging/python-django-tagging.SlackBuild b/python/python-django-tagging/python-django-tagging.SlackBuild
index 9946c63fd2..8413f17584 100644
--- a/python/python-django-tagging/python-django-tagging.SlackBuild
+++ b/python/python-django-tagging/python-django-tagging.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for python-django-tagging
-# Copyright 2015 Mario Preksavec, Zagreb, HR
+# Copyright 2015, 2016 Mario Preksavec, Zagreb, Croatia
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -24,7 +24,7 @@
PRGNAM=python-django-tagging
SRCNAM=django-tagging
-VERSION=${VERSION:-0.3.4}
+VERSION=${VERSION:-0.4.3}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -70,12 +70,10 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-patch -p1 <$CWD/patches/fix_calc_tag_weight
-
python setup.py install --root=$PKG
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a CHANGELOG.txt INSTALL.txt LICENSE.txt README.txt docs/overview.txt \
+cp -a CHANGELOG.txt LICENSE.txt README.rst \
$PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
diff --git a/python/python-django-tagging/python-django-tagging.info b/python/python-django-tagging/python-django-tagging.info
index 6eec463aab..2def0aef39 100644
--- a/python/python-django-tagging/python-django-tagging.info
+++ b/python/python-django-tagging/python-django-tagging.info
@@ -1,8 +1,8 @@
PRGNAM="python-django-tagging"
-VERSION="0.3.4"
+VERSION="0.4.3"
HOMEPAGE="https://pypi.python.org/pypi/django-tagging"
-DOWNLOAD="https://pypi.python.org/packages/source/d/django-tagging/django-tagging-0.3.4.tar.gz"
-MD5SUM="f9a8782516f5488bc48038a374428243"
+DOWNLOAD="https://pypi.debian.net/django-tagging/django-tagging-0.4.3.tar.gz"
+MD5SUM="0da5b6090a4352a8edcaff0f51c37adb"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="python-django"