summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Barry J. Grundy2016-08-26 22:53:15 +0200
committer David Spencer2016-08-28 01:22:59 +0200
commitac468a03b27a8ab8559f5b0fe7f3a9ba8d47e198 (patch)
tree5bc24bc0eb939fd11b82a7e204fee094333ca661
parent6b2c5aeca7e3ed8d6bb0120c7c27014e9b44c2d0 (diff)
downloadslackbuilds-ac468a03b27a8ab8559f5b0fe7f3a9ba8d47e198.tar.gz
python/artifacts: Added (ForensicArtifacts.com Artifact Repository).
Signed-off-by: David Spencer <idlemoor@slackbuilds.org>
-rw-r--r--python/artifacts/README9
-rw-r--r--python/artifacts/artifacts.SlackBuild86
-rw-r--r--python/artifacts/artifacts.info10
-rw-r--r--python/artifacts/slack-desc19
4 files changed, 124 insertions, 0 deletions
diff --git a/python/artifacts/README b/python/artifacts/README
new file mode 100644
index 0000000000..3f6680deb1
--- /dev/null
+++ b/python/artifacts/README
@@ -0,0 +1,9 @@
+artifacts - ForensicArtifacts.com Artifact Repository
+
+A free, community-sourced, machine-readable knowledge base of forensic
+artifacts that the world can use both as an information source and within
+other tools.
+
+For more information see: https://github.com/ForensicArtifacts/artifacts
+
+PyYAML is a run time dependancy.
diff --git a/python/artifacts/artifacts.SlackBuild b/python/artifacts/artifacts.SlackBuild
new file mode 100644
index 0000000000..1f5c7d3125
--- /dev/null
+++ b/python/artifacts/artifacts.SlackBuild
@@ -0,0 +1,86 @@
+#!/bin/sh
+
+# Slackware build script for artifacts
+# Copyright 2016 Barry Grundy <bgrundy[at]linuxleo.com>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+#
+# New submission August 2016, Barry J. Grundy.
+
+PRGNAM=artifacts
+VERSION=${VERSION:-20160713}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a ACKNOWLEDGEMENTS AUTHORS LICENSE README $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/artifacts/artifacts.info b/python/artifacts/artifacts.info
new file mode 100644
index 0000000000..6ea3c71b45
--- /dev/null
+++ b/python/artifacts/artifacts.info
@@ -0,0 +1,10 @@
+PRGNAM="artifacts"
+VERSION="20160713"
+HOMEPAGE="https://github.com/ForensicArtifacts/artifacts"
+DOWNLOAD="https://pypi.python.org/packages/36/83/429bf4858ec3dcf579f1cdaa1634fcc88d32b4ae4194774033617d7de3d6/artifacts-20160713.tar.gz"
+MD5SUM="1b602aa7d5ed680396af3a8df54f8bc1"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="PyYAML"
+MAINTAINER="Barry J. Grundy"
+EMAIL="bgrundy<at>linuxleo.com"
diff --git a/python/artifacts/slack-desc b/python/artifacts/slack-desc
new file mode 100644
index 0000000000..3257edc4d7
--- /dev/null
+++ b/python/artifacts/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+artifacts: artifacts (ForensicArtifacts.com Artifact Repository)
+artifacts:
+artifacts: A free, community-sourced, machine-readable knowledge base of
+artifacts: forensic artifacts that the world can use both as an information
+artifacts: source and within other tools.
+artifacts:
+artifacts: Homepage: https://github.com/ForensicArtifacts/artifacts
+artifacts:
+artifacts:
+artifacts:
+artifacts: