summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Dimitris Zlatanidis2016-08-19 13:47:30 +0200
committer Willy Sudiarto Raharjo2016-08-20 02:51:15 +0200
commitb26ca3ce3769a3d69dca3947683753116d69b169 (patch)
tree44dc1e87d47fd360bf92c57a556382b493d90e95
parenteccee0db09fe499c397933a2f2535d3d2f6c66ce (diff)
downloadslackbuilds-b26ca3ce3769a3d69dca3947683753116d69b169.tar.gz
libraries/pyqode.core: Updated for version 2.10.0.
Signed-off-by: Dimitris Zlatanidis <d.zlatanidis@gmail.com>
-rw-r--r--libraries/pyqode.core/pyqode.core.SlackBuild12
-rw-r--r--libraries/pyqode.core/pyqode.core.info8
2 files changed, 10 insertions, 10 deletions
diff --git a/libraries/pyqode.core/pyqode.core.SlackBuild b/libraries/pyqode.core/pyqode.core.SlackBuild
index 8246486406..cd6a8c4770 100644
--- a/libraries/pyqode.core/pyqode.core.SlackBuild
+++ b/libraries/pyqode.core/pyqode.core.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for pyqode.core
-# Copyright 2014 Dimitris Zlatanidis Greece-Orestiada
+# Copyright 2014-2016 Dimitris Zlatanidis Orestiada, Greece
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -23,13 +23,13 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=pyqode.core
-VERSION=${VERSION:-2.0.0}
+VERSION=${VERSION:-2.10.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
- i?86) ARCH=i486 ;;
+ i?86) ARCH=i586 ;;
arm*) ARCH=arm ;;
*) ARCH=$( uname -m ) ;;
esac
@@ -40,8 +40,8 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
@@ -69,7 +69,7 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python setup.py install --root=$PKG
+python3 setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
diff --git a/libraries/pyqode.core/pyqode.core.info b/libraries/pyqode.core/pyqode.core.info
index 0363740189..bc20b3c0b0 100644
--- a/libraries/pyqode.core/pyqode.core.info
+++ b/libraries/pyqode.core/pyqode.core.info
@@ -1,10 +1,10 @@
PRGNAM="pyqode.core"
-VERSION="2.0.0"
+VERSION="2.10.0"
HOMEPAGE="https://github.com/pyQode/pyqode.core"
-DOWNLOAD="https://pypi.python.org/packages/source/p/pyqode.core/pyqode.core-2.0.0.tar.gz"
-MD5SUM="b7c83ce44850242165b283db313dc97d"
+DOWNLOAD="https://pypi.python.org/packages/ec/9a/e1f7559ea080e5fbe0b46c2ff2cbe3c8dc88c0eb85966427e51c4102ad15/pyqode.core-2.10.0.tar.gz"
+MD5SUM="4f0348f3c5f3d26dea0119c3c515101b"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES="Pygments"
+REQUIRES="Pygments pyqode.qt python3-future"
MAINTAINER="Dimitris Zlatanidis"
EMAIL="d.zlatanidis@gmail.com"