summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Johannes Schoepfer2016-07-28 12:06:12 +0200
committer Willy Sudiarto Raharjo2016-07-30 03:28:31 +0200
commit29e7b0e5f18951eaa5860a730b7f634666ef4d3c (patch)
tree029d53bd4209d62a2ac67db96a2e1216965c6443
parent78535101aedc210013e3572820d4ff391b24ed70 (diff)
downloadslackbuilds-29e7b0e5f18951eaa5860a730b7f634666ef4d3c.tar.gz
games/oolite: Added (an open-world space opera).
Signed-off-by: David Spencer <idlemoor@slackbuilds.org>
-rw-r--r--games/oolite/README6
-rw-r--r--games/oolite/doinst.sh7
-rw-r--r--games/oolite/oolite.SlackBuild108
-rw-r--r--games/oolite/oolite.info10
-rw-r--r--games/oolite/slack-desc19
5 files changed, 150 insertions, 0 deletions
diff --git a/games/oolite/README b/games/oolite/README
new file mode 100644
index 0000000000..14d0ef8e11
--- /dev/null
+++ b/games/oolite/README
@@ -0,0 +1,6 @@
+Oolite is inspired by the 8-bit classic Elite, and many aspects of
+gameplay will be familiar to players of that game. In the tradition
+of open-world games, there's no overall story: you can be a
+millionaire trader, a veteran combateer, a feared pirate, a lonely
+miner, a notorious smuggler, or all of them, or something else
+entirely, based on your own actions.
diff --git a/games/oolite/doinst.sh b/games/oolite/doinst.sh
new file mode 100644
index 0000000000..2472345872
--- /dev/null
+++ b/games/oolite/doinst.sh
@@ -0,0 +1,7 @@
+#!/bin/sh
+if [ -x /usr/bin/update-mime-database ]; then
+ /usr/bin/update-mime-database usr/share/mime >/dev/null 2>&1
+fi
+if [ -x /usr/bin/update-desktop-database ]; then
+ /usr/bin/update-desktop-database -q usr/share/applications
+fi
diff --git a/games/oolite/oolite.SlackBuild b/games/oolite/oolite.SlackBuild
new file mode 100644
index 0000000000..f57b9aee21
--- /dev/null
+++ b/games/oolite/oolite.SlackBuild
@@ -0,0 +1,108 @@
+#!/bin/sh
+
+# Slackware build script for oolite
+
+# Copyright 2016 Johannes Schoepfer, Herrenberg, BW, Germany
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=oolite
+VERSION=${VERSION:-1.84}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i586"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf oolite-source-$VERSION
+tar vxf $CWD/oolite-source-$VERSION.tar.bz2
+cd oolite-source-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+source /usr/share/GNUstep/Makefiles/GNUstep.sh
+export GNUSTEP_MAKEFILES=/usr/share/GNUstep/Makefiles
+sed -i "/ADDITIONAL_OBJSLKFLAGS/s/=/= -fobjc-exceptions ${SLKFLAGS}/" GNUmakefile
+make -f libjs.make debug=no
+make -f Makefile ESPEAK=yes release-deployment
+
+mkdir -p $PKG/usr/share/oolite
+mv oolite.app/* $PKG/usr/share/oolite/
+
+#install startscript
+mkdir $PKG/usr/bin
+cat << EOF > $PKG/usr/bin/oolite
+#!/bin/sh
+
+# Start oolite
+
+cd /usr/share/oolite
+./oolite
+EOF
+chmod 755 $PKG/usr/bin/oolite
+
+# icon
+install -D -m644 installers/FreeDesktop/oolite-icon.png $PKG/usr/share/pixmaps/oolite-icon.png
+# .desktop file
+install -D -m644 installers/FreeDesktop/oolite.desktop $PKG/usr/share/applications/oolite.desktop
+# documentation
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+install -D -m644 Doc/AdviceForNewCommanders.pdf Doc/OoliteReadMe.pdf Doc/OoliteRS.pdf $PKG/usr/doc/$PRGNAM-$VERSION
+
+find $PKG -type f -exec file {} + | fgrep -e "executable" -e "shared object" | fgrep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/install
+cat $CWD/doinst.sh > $PKG/install/doinst.sh
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -p -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/games/oolite/oolite.info b/games/oolite/oolite.info
new file mode 100644
index 0000000000..011786cf38
--- /dev/null
+++ b/games/oolite/oolite.info
@@ -0,0 +1,10 @@
+PRGNAM="oolite"
+VERSION="1.84"
+HOMEPAGE="http://www.oolite.org/"
+DOWNLOAD="https://github.com/OoliteProject/oolite/releases/download/1.84/oolite-source-1.84.tar.bz2"
+MD5SUM="538e4249dbf4d3418216e0bdb7cbf408"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="espeak gnustep-base OpenAL"
+MAINTAINER="Johannes Schoepfer"
+EMAIL="<slackbuilds[at]schoepfer[dot]info>"
diff --git a/games/oolite/slack-desc b/games/oolite/slack-desc
new file mode 100644
index 0000000000..a82fae84f6
--- /dev/null
+++ b/games/oolite/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The \"handy ruler\" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':'.
+
+ |-----handy-ruler------------------------------------------------------|
+oolite: oolite (an open-world space opera)
+oolite:
+oolite: Oolite is inspired by the 8-bit classic Elite, and many aspects of
+oolite: gameplay will be familiar to players of that game. In the tradition
+oolite: of open-world games, there's no overall story: you can be a
+oolite: millionaire trader, a veteran combateer, a feared pirate, a lonely
+oolite: miner, a notorious smuggler, or all of them, or something else
+oolite: entirely, based on your own actions.
+oolite:
+oolite: http://www.oolite.org/
+oolite: